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Description of Work

The ArgoKeys lending application has created the ability to accept messages from the Jack
Henry jXchange enterprise application. This user guide provides instructions designed for third-
party vendors to configure and consume messages provided by jXchange and ArgoKeys.
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Overview

ArgoKeys has created a service which exposes ArgoKeys functionality through jXchange,
allowing authorized external service consumers to interact with ArgoKeys via web service
requests.
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ArgoKeys Preinstall Steps

eSign Configuration Settings
Obtain the following eSign configurations from the eSign/Synergy team:

● URL for the eSign Service
● eSign Host System
● eSign Host System FIID for the session
● eSign domain and user name to submit documents
● eSign service password
● eSign flatten parameter for use with TotaleAtlas 2016 or higher (currently not supported)
● Synergy Organization
● Synergy Institution Number
● Synergy File Room Name
● Synergy Vocabulary (default is ArgoKeys)

Sample:

 

 

Installing OFI
1. Navigate to KeysServices Details to set the FTP credentials.

The Web.config path auto populates in the Browse text box.
2. Navigate to the installation location to obtain KeysServices OFI – FTP Configurations.
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OFI Service Config
OFI and eSign can both be configured for use at the same time. eSign is the default service. If
eSign is not used, OFI is the next default option. If neither service is available, the next option is
to use PDFs that are dropped to a server file. Substitute real values for the example values
used for jXchange Service Environment, User Name, Password, and URL obtained from
IDG/jX personal.

CBRM > Maintenance > Region > Select Region > Configure > Enterprise Eventing
Service Configuration

Clear cache if changes are required.
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CBRM > Maintenance > Office

Input or verify ABA Number on the General Info tab of the Office Profile that correlates to the
branch that is used in the PltfmAppAdd GenDocs request.

Clear cache if changes are required.

NOTE
jXchange is expecting the nine-digit ABA Number.
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Currently Supported Messages

Message
Service Dictionary
Supported Description

PltfmAppAdd X Add a new Loan Application or Deposit
Account to the ArgoKeys System.

PltfmProdSrch X Search for and filter products based on criteria
provided by the user.

SvcDictSrch N/A Provides details about canonical values used
in other messages.

PltfmProdInq

PltfmDocInq Yes Provides support for a consumer to send a
Document Inquiry Request and receive a
Document Inquiry Response.

PltfmDocStatInq Yes Provides support for a consumer to send a
Document Status Inquiry Request and receive
a Document Status Inquiry Response.

PltfmEntityValidate
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Ping Message

The Ping Message response echoes back the ping request. SvcProdVer indicates the
provider's product version number.

The appropriate ArgoKeys code version number from the primary WebHost Assembly was
incorporated into the ping message so that consumers may code to the appropriate ArgoKeys
code version when patch notes are delivered to them. The Ping message has been modified to
include SvcProdVer containing the appropriate ArgoKeys code version.

Ping Message Request Example
 

 

Ping Message Response Example
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Validation and Error Messages

Customer Validation
The customer validation logic was rearchitected. Validation for new customers (origination) is
unchanged. Validation for existing customers (origination and fulfillment) was modified so that it
occurs the same way for both origination and fulfillment and is performed only when the
WARNCIF.ini setting is enabled ("YES").

When validation occurs, it is the same validation that occurs with traditional ArgoKeys when
customers are added as owners during new account setup (implemented with task 173984 for
Service Enablement).

The following validation outline is taken from the testing document for the task, with changes:

● Non-Overrideable:

○ The owner’s relationship code must be present and valid for the ownership, state, and
account type combination.

● Overrideable:

○ Mailing Address Line 1 is present.
○ Mailing City is present.
○ If mailing address is domestic, Mailing State and Mailing ZIP are present.
○ If mailing address is foreign, Mailing Country is present.
○ TIN Type is present.
○ IRS Address Line 1 is present.
○ IRS City is present.
○ If IRS address is domestic, IRS State and IRS ZIP are present.
○ If IRS address is foreign, IRS Country is present.
○ If TIN Type is not A:

■ If TIN is not present or TIN Type does not resolve to IRS reportable = N, and TIN type
does not resolve to IRS reportable = A or BPSETING.ALIENREQ is not “NO”, then
TIN is present.

○ If CIF Display Options Editor has the Multiple IDs option selected for new setup:

■ Customers have one or more IDs.
■ If Multiple ID Editor (MLID) is configured to require ID Expiration Date for the ID type

and customer type, the ID for that type and customer type has an Expiration Date.
■ If MLID is configured to require Issued By for the ID type and customer type, the ID for

that type and customer type has a value for Issued By.
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■ If MLID is configured to require Place of Issuance for the ID type and customer type,
the ID for that type and customer type has a value for Place of Issuance.

■ If MLID is configured to require Issue Date for the ID type and customer type and
Issued By is a state that can have Issue Date = 1, the ID for that type and customer
type has a value for Issue Date.

■ If MLID is configured to require Contact Date for the ID type and customer type, the ID
for that type and customer type has a value for Contact Date.

■ If MLID is configured to require Verification Code for the ID type and customer type,
the ID for that type and customer type has a value for Verification Code.

■ If ID Expiration Date is populated and is earlier than the current date, the ID
Expiration Date is today or later.

○ If User-Defined CIF Field Validation (CUFV) is configured to Require or Override for
Mailing Address Street 2 for the customer type, CFNA3 Mailing Address Street 2 has a
value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address Street 1 for the
customer type, CFPFA1 Physical Address Street 1 has a value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address Street 2 for the
customer type, CFPFA2 Physical Address Street 2 has a value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address City for the customer
type, CFPFCY Physical Address City has a value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address State for the customer
type, CFPFST Physical Address State has a value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address ZIP for the customer
type, CFPFZC Physical Address ZIP has a value for the customer type.

○ If CUFV is configured to Require or Override for Physical Address Country for the
customer type, CFPFFC Physical Address Country has a value for the customer type.

○ If CUFV is configured to Require or Override for Birthdate for personal customers,
CFBIR6 Birthdate has a value for personal customers.

○ If CUFV is configured to Require or Override for Home Phone for personal customers,
CFHPHO Home Phone has a value for personal customers.

○ If CUFV is configured to Require or Override for Employer Name for personal customers,
CFEMPL Employer Name has a value for personal customers.

○ If CUFV is configured to Require or Override Gender for personal customers, CFSEX
Gender has a value for personal customers.

○ If CUFV is configured to Require or Override for Home Cell Phone for personal
customers, CFCEL1 Home Cell Phone has a value for personal customers.

○ If CUFV is configured to Require or Override for Home Fax Number for personal
customers, CFFAX1 Home Fax Number has a value for personal customers.

○ If CUFV is configured to Require or Override for Branch Number for the customer type,
CFBRNN Branch Number has a value for the customer type.
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○ If CUFV is configured to Require or Override for TIN Status for the customer type,
CFTINS TIN Status has a value for the customer type.

○ If CUFV is configured to Require or Override for TIN Certification Date for the customer
type and the TIN Status has a value, CFTND6 TIN Certification Date has a value for the
customer type.

○ If CUFV is configured to Require or Override for Business Phone for the customer type,
CFBPHO Business Phone has a value for the customer type.

○ If CUFV is configured to Require or Override for Email Address for the customer type,
CFEML1 Email Address has a value for the customer type.

○ If CUFV is configured to Require or Override for Occupation/Nature of Business for the
customer type, CFOCPCD Occupation/Nature of Business has a value for the customer
type.

○ If CUFV is configured to Require or Override for Other Fax for the customer type,
CFFAX2 Other Fax has a value for the customer type.

○ If CUFV is configured to Require or Override for Other Cell Phone for the customer type,
CFCEL2 Other Cell Phone has a value for the customer type.

○ If CUFV is configured to Require or Override for Other Email for the customer type,
CFEML2 Other Email has a value for the customer type.

○ If CUFV is configured to Require or Override for Business Phone 2 for the customer type,
CFB2PHON Business Phone 2 has a value for the customer type.

○ If CUFV is configured to Require or Override for Home Phone 2 for the customer type,
CFH2PHON Home Phone 2 has a value for the customer type.

Validation Messages
Error ID Description

71200 Validation Failed: Invalid Region Code.

71201 Validation Failed: Invalid Account Type.

71202 Validation Failed: Invalid Primary Account Type for a Deposit Account.

71202 Validation Failed: Invalid Primary Account Type for a Loan Account.

71203 Validation Failed: Invalid Secondary Account Type for a Checking Account.

71203 Validation Failed: Invalid Secondary Account Type for a Loan Account.

71203 Validation Failed: Invalid Secondary Account Type a Savings Account.

71204 Validation Failed: Open Floor Amount cannot be greater than the Open Ceiling
Amount.
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Error ID Description

71205 Validation Failed: Product Term Floor Amount cannot be greater than the
Product Term Ceiling Amount.

71206 Validation Failed: Invalid Branch Code.

71206 Validation Failed: Branch Code is missing or invalid for Customer.

71207 Validation Failed: Invalid Customer Type.

71208 Validation Failed: Invalid Product Term Type for a Deposit Account.

71208 Validation Failed: Invalid Purpose Code format.

71209 Validation Failed: Invalid Rate Type.

71210 Validation Failed: Invalid Collateral ID.

71210 Validation Failed: Invalid Collateral ID format. ID is not in GUID format.

71211 Validation Failed: Invalid Purpose Code.

71212 Validation Failed: Region Code and Customer Type are required when providing
Category Code.

71212 Validation Failed: Region and Customer required for Category Code.

71213 Validation Failed: Invalid Ownership Type.

71214 Validation Failed: Invalid Region, Account Type, and Product Code combination.

71215 Validation Failed: At least one card opt-in entry must be present.

71215 Validation Failed: Only one overdraft entry allowed.

71215 Validation Failed: Invalid Overdraft Opt In Type.

71216 Validation Failed: Invalid Customer Name.

71217 Validation Failed: Invalid Primary Deposit Account Type.

71217 Validation Failed: Invalid Primary Time Deposit Account Type.

71217 Validation Failed: Primary Account Type for Commercial Lending Account must
be Installment, Line of Credit or Letter of Credit.

71217 Validation Failed: Primary Account Type for Consumer Lending Account must
be Installment or Line of Credit.

71217 Validation Failed: Primary Account Type for Residential Real Estate Lending
Account must be Installment or Line of Credit.

71218 Validation Failed: Missing Tax Information.
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Error ID Description

71218 Validation Failed: Invalid Certification Code.

71218 Validation Failed: Valid certification code date is required for Customer.

71218 Validation Failed: Tax ID is required for Customer.

71218 Validation Failed: Invalid TINCode for Customer.

71218 Validation Failed: TINCode is invalid for Customer.

71219 Validation Failed: Duplicate Source of Funds.

71219 Validation Failed: Invalid Source of Funds code.

71219 Validation Failed: Only one Source of Funds can be Primary.

71219 Validation Failed: A Primary Source of Funds is required.

71219 Validation Failed: Source of funds amount must be greater than $0.00.

71219 Validation Failed: Invalid Source of Funds Primary Type.

71220 Validation Failed: Invalid Account Ownership Type.

71221 Validation Failed: Invalid Birth Date for Customer.

71222 Validation Failed: Customer must have at least one home or work phone
number.

71223 Validation Failed: Relationship Code is for empty or invalid for selected Account
Type Ownership code.

71224 Validation Failed: Customer cannot contain an address for both Mailing and
Physical.

71224 Validation Failed: City for Customer is required.

71224 Validation Failed: Country for Customer is required.

71224 Validation Failed: Invalid Customer Address Type.

71224 Validation Failed: Customer Postal Code is required.

71224 Validation Failed: Customer State is required.

71224 Validation Failed: Customer Street Address is required.

71224 Validation Failed: Invalid Customer Country.

71224 Validation Failed: Invalid Customer State.

71224 Validation Failed: Customer must contain one and only one Physical Address.

ArgoKeys jXchange User Guide 17 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Error ID Description

71224 Validation Failed: Customer must contain one and only one Customer Address.

71224 Validation Failed: Customer must contain one and only one IRS Address.

71224 Validation Failed: Customer must have mailing, physical and IRS addresses.

71224 Validation Failed: Primary customer must have a mailing address.

71224 Validation Failed: Customer must have at least one Physical Address.

71224 Validation Failed: Customer must contain one and only one Physical Address.

71224 Validation Failed: Customer must contain one and only one Customer Address.

71224 Validation Failed: Customer must contain one and only one IRS Address.

71224 Validation Failed: Customer must have mailing, physical, and IRS addresses.

71224 Validation Failed: Primary customer must have a mailing address.

71225 Validation Failed: Invalid Customer ID Code.

71225 Validation Failed: ID Number is required for Customer and ID Type.

71225 Validation Failed: Contact Date is required for Customer and ID Type.

71225 Validation Failed: Expiration Date is required for Customer and ID Type.

71225 Validation Failed: Invalid State for Customer and ID Type.

71225 Validation Failed: Issue Date is required for Customer and ID Type.

71225 Validation Failed: Place of Issuance is required for Customer and ID Type.

71225 Validation Failed: ID Verified By is required for Customer and ID Type.

71225 Validation Failed: Customer has duplicate ID Query Codes for ID.

71225 Validation Failed: Other Description is required for customer and ID Type.

71225 Validation Failed: Customer has an ID with an invalid code.

71225 Validation Failed: Id Number is required for customer and ID Type.

71225 Validation Failed: The ID Expiration Date should be today or later for customer
and ID Type.

71225 Validation Failed: Customer has invalid ID Query Codes for ID.

71225 Validation Failed: Customer has invalid ID Query Data Type for Query Code.

71225 Validation Failed: Primary ID indicator must be true or false for ID Type.

71225 Validation Failed: Customer {0} has duplicate ID Query Codes for ID {1}.
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Error ID Description

71226 Validation Failed: Invalid Tax Plan Code.

71226 Validation Failed: Tax Plan Code is required for IRA accounts.

71227 Validation Failed: Only one Customer may be designated as Primary.

71227 Validation Failed: Invalid Customer Owner Relationship Code.

71227 Validation Failed: One Customer must be designated as Primary.

71228 Validation Failed: The SubType filter is invalid.

71229 Validation Failed: DictionaryName is required.

71230 Validation Failed: ServiceType is required.

71231 Validation Failed: Invalid Service Dictionary Type/name:{Service Dictionary Type
sent by Consumer}/{Service Dictionary Name sent by Consumer}.

71232 Validation Failed: Invalid Service Dictionary Type/Name/Element Name:
{Service Dictionary Type sent by Consumer}/{Service Dictionary Name sent by
Consumer}/{Service Dictionary Element sent by Consumer}.

71233 Validation Failed: Missing or Invalid PltfmAcctTypeCode filter.

71234 Validation Failed: Proceeds Amount cannot be blank and must be greater than
$0.00.

71235 Validation Failed: Loan term is required and the units must be Months, Years,
SemiMonthly, or AtMat. Loan Term Count must be greater than zero. The loan
cannot exceed a term of 30 years.

71236 Validation Failed: Collateral Status must be New or Used for a Title Vehicle
Collateral Type.

71237 Validation Failed: Invalid Collateral Holder first and last name or common name.

71238 Validation Failed: Invalid Collateral Holder address.

71239 Validation Failed: Borrower must have a first and last name.

71240 Validation Failed: Co-Borrower must have a first and last name.

71241 Validation Failed: Invalid Borrower address.

71241,
71242

Validation Failed: Invalid State Code.

71242 Validation Failed: Invalid Co-Borrower address.

71243 Validation Failed: Invalid Borrower Tax ID number.
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Error ID Description

71244 Validation Failed: Invalid Co-Borrower Tax Id number.

71245 Validation Failed: Borrower Judgment Exist value must be true or false.

71245 Validation Failed: Borrower Alien Resident value must be true or false.

71245 Validation Failed: Borrower Bankruptcy value must be true or false.

71245 Validation Failed: Borrower Foreclosure Exists value must be true or false.

71245 Validation Failed: Borrower Lawsuit Exists value must be true or false.

71245 Validation Failed: Borrower Other Dlq Exists value must be true or false.

71245 Validation Failed: Borrower Down payment borrowed value must be true or
false.

71245 Validation Failed: Borrower Endorsing Co-Borrower exists value must be true or
false.

71245 Validation Failed: Borrower Non U.S. Citizen value must be true or false.

71245 Validation Failed: Borrower Alimony Exists value must be true or false.

71245 Validation Failed: Borrower OccupProp value must be true or false.

71245 Validation Failed: Borrower PriorPropOwner value must be true or false.

71245 Validation Failed: Borrower Other Foreclosure Exists value must be true or
false.

71245 Validation Failed: Co-Borrower Other Foreclosure Exists value must be true or
false.

71246 Validation Failed: Alien Resident value must be True or False.

71246 Validation Failed: Alimony Exists value must be True or False.

71246 Validation Failed: Bankruptcy value must be True or False.

71246 Validation Failed: Co-Borrower Judgment Exist value must be true or false.

71246 Validation Failed: Co-Borrower Alien Resident value must be true or false.

71246 Validation Failed: Co-Borrower Bankruptcy value must be true or false.

71246 Validation Failed: Co-Borrower Foreclosure Exists value must be true or false.

71246 Validation Failed: Co-Borrower Lawsuit Exists value must be true or false.

71246 Validation Failed: Co-Borrower Other Dlq Exists value must be true or false.
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Error ID Description

71246 Validation Failed: Co-Borrower Down payment borrowed value must be true or
false.

71246 Validation Failed: Co-Borrower Endorsing Co-Borrower exists value must be
true or false.

71246 Validation Failed: Co-Borrower Non U.S. Citizen value must be true or false.

71246 Validation Failed: Co-Borrower Alimony Exists value must be true or false.

71246 Validation Failed: Co-Borrower OccupProp value must be true or false.

71246 Validation Failed: Co-Borrower PriorPropOwner value must be true or false.

71246 Validation Failed: Invalid Asset Type value.

71247 Validation Failed: Invalid or missing Region Code filter.

71248 Validation Failed: Co-Borrower Relationship code is required and must be Co-
Borrower, Co-Signer, or Guarantor.

71248 Validation Failed: Invalid Co-Borrower Relationship code.

71249 Validation Failed: Loan App Type is required and must be a valid value.

71254 Validation Failed: Invalid Other Income Frequency code.

71254 Validation Failed: Invalid Other Income Source code.

71255 Validation Failed: The SubType filter is missing.

71257 Validation Failed: Residential Code is required and must be a valid value when
property is occupied.

71267 Validation Failed: Borrower Housing Disposition Type must be Rent, Own, or
Parent.

71268 Validation Failed: Borrower Previous Housing Disposition Type must be Rent,
Own, or Parent.

71269 Validation Failed: Co-Borrower Housing Disposition Type must be Rent, Own, or
Parent.

71269 Validation Failed: Invalid Value. IntTerm must be a positive value.

71269 Validation Failed: Invalid Value. CDTerm must be a positive value.

71269 Validation Failed: Invalid Value. RateRevTerm must be a positive value.

71270 Validation Failed: Co-Borrower Previous Housing Disposition Type must be
Rent, Own, or Parent.
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Error ID Description

71273 Validation Failed: Invalid Borrower Email Type for Borrower.

71273 Validation Failed: An email address is required for borrower for email type
PrimaryEmail.

71273 Validation Failed: Borrower has duplicate email types.

71273 Validation Failed: Invalid CoBorrower Email Type for CoBorrower.

71273 Validation Failed: An email address is required for coborrower for email type
PrimaryEmail.

71273 Validation Failed: Co-Borrower has duplicate email types.

71276 Validation Failed: Account Class Code is required.

71276 Validation Failed: Invalid Account Class Code.

71277 Validation Failed: Invalid value for Sales Person.

71278 Validation Failed: Account Service Charge Type is required.

71279 Validation Failed: Account Withholding Reason is required.

71279 Validation Failed: Account Withholding Reason is invalid.

71280 Validation Failed: Account Accrual method is required.

71280 Validation Failed: Invalid Account Accrual method.

71284 Validation Failed: CD Payment Method is required.

71285 Validation Failed: Interest Term value is required.

71285 Validation Failed: A value for Interest Term Units is required.

71285 Validation Failed: Invalid units for Interest Term.

71285 Validation Failed: Interest Term value is invalid for the selected Interest Term
Units.

71286 Validation Failed: CD Start Payment Date is required and must be after
01/01/1753.

71288 Validation Failed: Rate type must be Fix or Vrbl.

71288 Validation Failed: CD Rate Type is required.

71290 Validation Failed: CD term unit must be Months or Days

71290 Validation Failed: Invalid CD Term Length. The maximum term for this product is
{} Days.
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Error ID Description

71290 Validation Failed: Invalid CD Term Length. The minimum term for this product is
{} Days.

71290 Validation Failed: Invalid CD Term Length. The maximum term for this product is
{} Months.

71290 Validation Failed: Invalid CD Term Length. The minimum term for this product is
{} Months.

71290 Validation Failed: Invalid CD term length.

71290 Validation Failed: CD term value and type are required.

71291 Validation Failed: Year Base Code is invalid.

71294 Validation Failed: Variable Rate Type is Required.

71296 Validation Failed: Invalid Value. Variable Rate Ceiling must be a positive value.

71296 Validation Failed: Invalid Value. Variable Rate Floor must be a positive value.

71296 Validation Failed: Invalid Value. Variable Rate must be a positive value.

71315 Validation Failed: Dormant Service Charge Waive is invalid.

71316 Validation Failed: Invalid Dormant Service Charge Waive and Service Charge
Waive type combination.

71317 Validation Failed: Statement Cycle is invalid.

71318 Validation Failed: Service Charge Cycle is invalid.

71319 Validation Failed: Interest Cycle is invalid.

71320 Validation Failed: The Interest Disposition Code is missing or invalid.

71321 Validation Failed: Interest Disposition Account type is missing or invalid.

71322 Validation Failed: Interest Disposition Account ID is missing.

71323 Validation Failed: Interest Rate Number is invalid.

71324 Validation Failed: The Rate Review Term Units is missing or invalid.

71325 Validation Failed: The Rate Variance code is missing or invalid.

71326 Validation Failed: The Rate Floor cannot be greater than the Rate Ceiling.

71327 Validation Failed: The Call Report Code is invalid.

71328 Validation Failed: The IRS Exempt Code is invalid.

71329 Validation Failed: Invalid Officer Code for Customer {0}.
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Error ID Description

71329 Validation Failed: Invalid Officer Role for Customer {0}.

71329 Validation Failed: Officer Roles must not be duplicated in the officer array for
Customer {0}.

71329 Validation Failed: The account must contain one primary officer.

71329 Validation Failed: The account Officer Code is required and must be a valid
value.

71329 Validation Failed: The account Officer Role is required and must be a valid
value.

71329 Validation Failed: Account Officer Roles must not be duplicated in the officer
array.

71329 Validation Failed: A primary officer is required for the customer {0}.

71329 Validation Failed: Invalid Officer Code for customer {0}.

71329 Validation Failed: Invalid Officer Role for customer {0}.

71333 Validation Failed: Exempt Code can only be submitted if Withholding Reason is
Do not Withhold.

71334 Validation Failed: Borrower Prior Property Owner Interest Declaration is
required.

71334 Validation Failed: Co-Borrower Prior Property Owner Interest Declaration is
required.

71334 Validation Failed: Borrower Prior Property Type Declaration is missing or invalid.

71334 Validation Failed: Borrower Prior Property Title Type Declaration is missing or
invalid.

71334 Validation Failed: Co-Borrower Prior Property Declaration is missing or invalid.

71334 Validation Failed: Co-Borrower Prior Property Title Type Declaration is missing
or invalid.

71335 Validation Failed: Real Estate Address County is not valid for chosen State.

71344 Validation Failed: Collateral CD Type is not valid.

71345 Validation Failed: Collateral Financial Institution Indicator is invalid.

71346 Validation Failed: Invalid Collateral Deposit Account Type.

71347 Validation Failed: Invalid Action Type for selected product.
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Error ID Description

71348 Validation Failed: Non-Taxable Income value must be true or false.

71349 Validation Failed: Only one employer can be primary for borrower.

71349 Validation Failed: Only one employer can be primary for co-borrower.

71349 Validation Failed: Invalid primary employer indicator for customer.

71349 Validation Failed: A primary employer is required for borrower.

71349 Validation Failed: A primary employer is required for co-borrower.

71349 Validation Failed: State is invalid for employer address.

71349 Validation Failed: Borrower employer term units must be months or years.

71349 Validation Failed: Co-borrower employer terms units must be months or years.

71349 Validation Failed: Invalid employer state code for co-borrower.

71349 Validation Failed: Co-borrower employer term units must be months or years.

71350 Validation Failed: Invalid owner code for collateral.

71350 Validation Failed: Invalid state code for collateral owner's address.

71350 Validation Failed: Invalid foreign indicator for collateral owner's address.

71350 Validation Failed: Invalid country for collateral owner's address.

71350 Validation Failed: A street address is required for collateral owner's address.

71350 Validation Failed: A city is required for collateral owner's address.

71350 Validation Failed: A state is required for collateral owner's address.

71350 Validation Failed: A postal code is required for collateral owner's address.

71350 Validation Failed: Invalid owner title code for collateral.

71350 Validation Failed: A common name is required for collateral owners.

71351 Validation Failed: Invalid Class Code for customer {0}.

71353 Validation Failed: Alien Resident value must be true or false for customer.

71354 Validation Failed: Invalid Alien W8Type for customer.

71355 Validation Failed: Invalid body type for a titled vehicle.

71356 Validation Failed: Matching Products are not available for the Consumer.

71358 Validation Failed: TIN certify indicator value must be true or false for customer.
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Error ID Description

71359 Validation Failed: Invalid Product Service Option Code for the Account.

71359 Validation Failed: Product Service Option Codes must not be duplicated for the
Account.

71360 Validation Failed: Invalid due diligence provider code.

71360 Validation Failed: Due diligence indicator value must be true or false.

71361 Validation Failed: Invalid value for Item Truncation.

71361 Validation Failed: A valid value for item truncation is required for the account.

71362 Validation Failed: Invalid value for Club Plan Account.

71362 Validation Failed: A valid value in the range of 0-9 is required for the Club Plan
Account.

71363 Validation Failed: PODRegType value must be true or false for the Account and
Customer Relationship Code.

71364 Validation Failed: Invalid Service Charge Waive Reason Code for the Account.

71365 Validation Failed: Number of account titles cannot exceed the allowed limit of 3.

71365 Validation Failed: One or more titles is missing from the Account Titling array.
Array should not contain any blank value.

71366 Validation Failed: State for beneficiary is required.

71366 Validation Failed: Invalid State provided for beneficiary.

71366 Validation Failed: Postal Code for beneficiary is required.

71366 Validation Failed: Country for beneficiary is required.

71366 Validation Failed: Invalid Country provided for beneficiary.

71368 Validation Failed: Penalty Code is invalid.

71369 Validation Failed: Statement Frequency Code is invalid.

71369 Validation Failed: CD Statement Frequency is required.

71370 Validation Failed: Automatic Renewal Type is required.

71370 Validation Failed: Invalid Automatic Renewal Type.

71371 Validation Failed: The interest day is invalid.

71372 Validation Failed: Service Charge Waive Expiration Date needs to be today or
later.
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Error ID Description

71374 Validation Failed: CIF number is required to generate docs or load account to
host.

71375 Validation Failed: Platform Id is required for Document Inquiry.

71375 Validation Failed: PltfmId field supports only values of type GUID.

71375 Validation Failed: Cannot have a Platform Id and Transaction Id on one inquiry.

71375 Validation Failed: Platform Id does not exist.

71375 Validation Failed: Transaction Id does not exist.

71376 Validation Failed: OFI Response Delivery Type is required for Document Inquiry.

71376 Validation Failed: OFI Response Delivery Type has an invalid value. The value
must be true.

71376 Validation Failed: OFI Response Delivery Type has an invalid value. The value
must be false.

71377 Validation Failed: Platform Document Status Id is required for Document Status
Inquiry.

71377 Validation Failed: PltfmDocStatId field supports values of type GUID.

71378 Validation Failed: Interest Disposition Account Type is invalid.

71379 Validation Failed: Interest Disposition Account Type is required.

71380 Validation Failed: Interest Disposition Account Number is invalid.

71381 Validation Failed: Interest Disposition Account Number is required.

71383 Validation Failed: Maturity Date is above or below product CD Term
requirements.

71384 Validation Failed: Class code is required for customer {0}.

71385 Validation Failed: No more than 20 customers are allowed for the account.
Incoming request has {0} customers.

71386 Validation Failed: Invalid account level security code.

71387 Validation Failed: Invalid Display Phone Format for Customer {0}.

71387 Validation Failed: Invalid Display Phone Format for Phone Type {0} and
Customer {1}.

71388 Validation Failed: The name of the person opening the business account is
required.
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Error ID Description

71389 Validation Failed: The title of the person opening the business account is
required.

71390 Validation Failed: The number of signatures required to execute power should
not be greater than 99.

71391 Validation Failed: Commercial Authorization Type is required.

71391 Validation Failed: Commercial Authorization Type is invalid.

71391 Validation Failed: Commercial Authorization Code is required.

71391 Validation Failed: The CommAuthType is missing or invalid for customer {0}.

71391 Validation Failed: The CommAuthType and CommAuthCode combination must
exist in the account-level CommAuthArray for customer {0}.

71392 Validation Failed: FinCEN Legal Entity value must be true or false for the
customer {}.

71392 Validation Failed: FinCEN Legal Entity value is required for the customer {}.

71393 Validation Failed: Commercial Authorization Code is invalid.

71393 Validation Failed: Commercial Authorization Type and Commercial Authorization
Code combination is invalid.

71393 Validation Failed: Commercial Authorizations cannot be duplicated.

71393 Validation Failed: The CommAuthCode is missing or invalid for customer {0}.

71393 Validation Failed: The CommAuthCode is invalid for CommAuthType={0} for
customer {1}.

71394 Validation Failed: Standard Industry Class value must be numeric and not more
than 4 digits long for the customer {0}.

71395 Validation Failed: Beneficial Owner Exclusion Code is required for the customer
{0}.

71395 Validation Failed: Beneficial Owner Exclusion Code is invalid for the customer
{0}.

71396 Validation Failed: Duplicate CommAuthType and CommAuthCode combinations
exist for customer {0}.

71397 The account contains a CommAuthType/CommAuthAgent combination that
does not have a corresponding customer-level CommAgentAuth entry.

71398 Validation Failed: NAICS Code is invalid for the customer {0}.
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Error ID Description

71399 Validation Failed: Document Delivery Code is required for Document Inquiry.

71399 Validation Failed: Document Delivery Code is invalid. Please ensure that the
selected delivery mechanism has been configured for.

80001 Validation Failed: Customer must have at least one ID.

PltfmEntityValidate Error Messages
Error ID Description

9999 First Name and Last Name or Com name is required.

9999 Street Address1 is required.

9999 City is required.

9999 State Code is required.

9999 State Code should be two character length.

9999 State Code is invalid.

9999 Postal Code is required.

9999 Postal Code Value should be numeric and of 5 or 9 character length.

9999 Country name is invalid.

System Error Messages

Error ID
Application
Layer Description

60099 The application encountered an error. Please contact an
application administrator or support.

60300 Service
Application

The service encountered a problem processing the request.
Please contact an application administrator or support.

60310–
60399

Service
Application

Reserved range, not currently implemented.

60400 Data Layer The data layer encountered a problem processing the
request. Please contact an application administrator or
support.
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Error ID
Application
Layer Description

60410 Data Layer Unable to complete action due to a data access error. Please
contact an application administrator or support.

60420 Data Layer Unable to complete action due to an Entity Framework error.
Please contact an application administrator or support.

60500 Database The database encountered an error processing the request.
Please contact an application administrator or support.

60510 Database The database could not process the requested action.
Please contact a system administrator.

60520 Database The database has encountered an internal or software-
related error. Please contact a database administrator.

60530 Database The database has encountered a fatal error while
processing. Please contact a database administrator.

60600 Web Service A service dependency encountered a problem processing
the request. Please contact an application administrator or
support.

60700 Web Service A service dependency returned an internal error. Please
contact an application administrator or support.

60710 Web Service A service dependency encountered a communication error.
Please contact an application administrator or support.

80300 eSign service communication is not available.

ADS Error Codes and Messages
No data to process

Session not initialized

Invalid request

Node error

Network communication error

NETBIOS function not active

Network request in process

Message canceled by the remote node
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Storage not available

Length error

Sequence mismatch on response

Error from NETBIOS

Session initialization in process

Task termination in process

Request timeout

Network already initialized

System error

Request timeout

Network initialization error

Thread start error

Insufficient storage

Semaphore create error

Invalid message type

Error from remote application. Detail in extended completion code.

Application error. Detail in extended completion code.

Catch-all error

Invalid input

Invalid output

Sequence number not found

Name server could not be found

Catch-all error

ADS Configuration Server may not be running

Server not found
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Error Overrides
Soft errors may be overridden by using either a fault error code specific to each type of error or
a blanket 9999999 error code to override all soft errors eligible for override. The override code is
sent in the ErrOvrRdInfoArray in the PltfmAppAdd request.

<ErrOvrRdInfoArray>
<ErrOvrRd>
<ErrCode>80001</ErrCode>
</ErrOvrRd>
</ErrOvrRdInfoArray>

If only overridable faults exist and an override code is present in the ErrOvrRdInfoArray, these
are returned in the <MsgRsHdr>.<MsgRecInfoArray> with an error category of Override. If there
are no hard faults, the application saves to the ArgoKeys database.

 

 

If both overridden and hard faults exist, all are returned in the <FaultHdr>.<FaultRecInfoArray>
overrides with an error category of Override and hard faults with an error category of Error. The
application is not saved to the ArgoKeys database until any fault errors are corrected.
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Filtering

ArgoKeys requires some of the messages supported by jXchange to contain filters, which
provide additional information to ArgoKeys about how to process the request. This section is a
summary of those filters. Jack Henry Enterprise Business Objects allow for a common filtering
array for service dictionary requests which allows you to add multiple filters. Filters can be
added by adding a SvcDictFilterInfo object to the filter array.

In addition to SvcDictFilterInfo array, the Product Search message () contains an array
named LnTraitType. The LnTraintType array can be used to filter by pre-defined loan traits.

SvcDictFilterInfo XML Example
 

 

SvcDictFilterInfo C# Example
 

 

LnTraitArrayXML Example
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SvcDictFilterInfo C# Example
 

 

Summary of Available Filters by Message
Platform Product Search - PltfmProdSrch
Filter Description Applicable Values

BrCode Branch Code 3 Character Branch Code
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Filter Description Applicable Values

CollatCode The Collateral Code as defined in
ArgoKeys.

LnTraitType The array that allows for filtering by
loan traits.

InitialRateOffer - If an initial rate is
offered for product

AutoPayOffer - If Automatic
Payment is an option for the
product

RE - Filters response to real estate-
specific products

Direct - Filters response to direct
loan products

Revol - Filters response to
revolving products

ConstOnly - Filters response to
construction-only products

ConstPerm - Filters response to
construction to perm products

HELOC - Filters response to home
equity line of credit

OpenCeilAmt The maximum amount allowed to
open a deposit account.

OpenFlrAmt The minimum amount required to
open a deposit account.

PlnType The Tax Plan types as approved by
the IRS.

HSA - Yes

Null/Blank - Non-HSA

PltfmAccTypeCode Describes the Account Type. If the
consumer sends Loan for the
Product Search message, then
they only receive loan products.

Loan

Deposit

PltfmCatCode The code that describes a grouping
of products being offered. It may be
promotional or marketing related.

Category Code from CBRM in
ArgoKeys
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Filter Description Applicable Values

PltfmClsfPrimType Types of platform products offered. CDA - Certificate of Deposit

DDA - Checking/Money Mkt

IRA - Individual Retirement
Account

ILA - Installment Loan

LTC - Letter of Credit

LOC - Line of Credit

TDA - Savings

SBA - Safe Deposit Box

PltfmClsfSecdType Elements further identifying the type
of Loan or Deposit instrument
being searched for.

● DDA:

○ N - Now
○ M - Money Market
○ C - Interest Checking
○ I - Non-Interest Bearing

● TDA:

○ Not Y= Regular Savings,
coded as R=Regular

○ Y= Club Account coded as
X= Club

● Loan:

○ S - Secured
○ U - Unsecured

PltfmCustType The Customer Type. This filter only
filters Category codes.

PER

BUS

PltfmProdDispType Platform product disposition type. Orign

OrignFulfill

ProdTermFlr The integer length of the term.

ProdTermUnits Years

Months
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Filter Description Applicable Values

Days

Indefinite

NA

PurpCode The Purpose Code as defined in
ArgoKeys.

RateType Types of Interest rates. Fix - Fixed

Vrbl - Variable

Adj - Adjustable

RegionCode The ArgoKeys Region Code
configured in CBRM. This filter only
filters Category codes.

3 Character Region Code

Platform Application Add - PltfmAppAdd
Filter Description Applicable Values

SubType Describes the Type of loan being
submitted. This filter is required in
order for ArgoKeys to process the
request. This filter is required.

● LnRes - A Residential Loan
● TDep - Time Deposit Account CD

or IRA
● Dep - Deposit Account Checking

or Savings
● LnCon - A Consumer Loan
● LnCom - A Commercial Loan

Service Dictionary Search - SvcDictSrch
SvcDictName Filter Description Applicable Values

PlftmProdSrch RateType Fix

Vrbl

Adj

PltfmAppAdd ActionScope F - Fulfillment

O - Origination

PltfmAppAdd BrCode Branch code
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SvcDictName Filter Description Applicable Values

PltfmAppAdd CollatCode Collateral code

PltfmAppAdd CustType Used in the service
dictionary search for
SigNumCnt to return the
default value from the
Account Setup Defaults in
Region Configuration.

P - Personal

B - Business

PltfmAppAdd PltfmClsfPrimType

PltfmAppAdd ProdCode

PltfmAppAdd RegionCode The ArgoKeys Region
Code configured in CBRM.
As some values from the
service dictionary are
retrieved from SilverLake
and SilverLake requires a
Region Code, this filter is
required. The filter is not
required when the
requested Service
Dictionary Element is
RegionCode.

3 Character Region
Code

PltfmAppAdd State Real estate collateral
location. Used for service
dictionary County search.

PltfmProdSrch AcctTypeCode Describes the Account
Type. This filter is required.

Loan

Deposit

PltfmProdSrch BrCode Branch Office

PltfmProdSrch CollatCode Collateral Code (Loans
only)

PltfmProdSrch LnTraitArray

PltfmProdSrch OpenCeilAmt

PltfmProdSrch OpenFlrAmt

PltfmProdSrch PlnType Plan Type (Deposits only) HSA
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SvcDictName Filter Description Applicable Values

PltfmProdSrch PltfmCatCode Category Code

PltfmProdSrch PltfmClsfPrimType CDA

DDA

IRA

SBA

TDA

ILA

LOC

LTC

PltfmProdSrch PltfmClsfSecdType C – Checking

I – Interest Bearing

M – Money Market

N – Now

R – Regular Savings

X - Club

U - Unsecured

S – Secured

PltfmProdSrch PltfmCustType Customer Type PER

BUS

PltfmProdSrch ProdTermCeil

PltfmProdSrch ProdTermFlr

PltfmProdSrch ProdTermUnits Days (Deposit &
Loans)

Months (Deposits &
Loans)

Indefinite (Loans only)

Semi-Monthly (Loans
only)
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SvcDictName Filter Description Applicable Values

Years (Loans only)

PltfmProdSrch PurpCode Purpose Code (Loans
only)

PltfmProdSrch RegionCode The ArgoKeys Region
Code configured in CBRM.
As some values from the
service dictionary are
retrieved from SilverLake
and SilverLake requires a
Region Code, this filter is
required. The filter is not
required when the
requested Service
Dictionary Element is
RegionCode.

3 Character Region
Code

PltfmEntityValidate Filters
A PltfmEntityValidate Service Dictionary request can also be filtered by the ValidateConfigId
element name.

Applicable filters are:

● RegionCode
● BrCode
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Canonical Value Info Array

Each Canonical Record can contain an array that can supply additional details about a
Canonical Record. This information is contained in the <CanocValDetail> and <CanocValInfo>
elements, which can provide necessary detail for each Canonical Record.

XML Example Response
 

 
 

 

User-Defined Fields Example and Details
The following table breaks down the canonical fields that are extracted from SilverLake.

● Bank Number is assumed due to SvcDictSrch requiring RegionCode.
● Green fields are the ElemConocVal and ElemConocValDesc mappings.
● Yellow fields are mapped to the CanocValInfoArray (one CanocValInfo instance per field).

ArgoKeys jXchange User Guide 42 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



● Data Type is an additional CanocValInfo instance generated by parsing the fifth position
character from the Field Name value.

○ FieldName: IN09N1 – Indicates a numeric data type
○ FieldName: IN09A1 – Indicates a character data type
○ FieldName: IN09D1 – Indicates a date data type

Field Length Type Description

NUMBANK 3.0 Numeric Bank Number

2 Character Application

10 Character Field Name

2.0 Numeric Field Length

2.0 Numeric Field Order

25 Character Field Description

1 Character New Account Entry

1.0 Numeric Number of Decimals

1 Character Edit Code

35 Character Default Value

3.0 Numeric Custom field 1

LIT – Field Order
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TIP
The highlighted elements are parsed from the Field Name value and are not mapped back
directly to a host field.

Platform Entity Validate - PltfmEntityValidate
What is returned in the service dictionary for a PltfmEntityValidate request and how to interpret
the response.

Description

The description is generated for a setting using the vendor, region, and branch. It also contains
information that indicates whether QualiFile® is enabled, the specific QualiFile® custom strategy
and customer type if applicable, and whether ID verification is enabled.

For example, if Qualifile® is enabled for region #001 branch #006, customer strategies exist for
personal customers, and ID verification is enabled, then the description appears as follows:

Vendor: ChexSystems, Region: 001, Branch: 006, QualiFile®: Yes(XXXXX), CustType: Per,
IDVer: Yes.

The description provides the consumer's user with all information about that particular setting.
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NOTE
The (XXXXX) in the description represents the actual QualiFile® strategy ID from region ID.

The applicability of branch-specific settings is controlled by whether the office has its own
ChexSystems client identifier configured. If a branch does not, that branch number never has a
setting in the list. Additionally, if QualiFile® strategy is not enabled in region configuration, then
the QualiFile® portion of the description would reflect that:

Vendor: ChexSystems, Region: 001, Branch: 006, QualiFile®: No, CustType: Per, IDVer:
Yes.

If QualiFile® custom strategy is enabled but there are no custom strategies defined, the
description would be:

Vendor: ChexSystems, Region: 001, Branch: 006, QualiFile®: Yes, IDVer: Yes.

Finally, the service dictionary search response also includes canonicals to assist the consumer
in constructing selection lists and other items. The following canonicals are always present:
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Notice of Action Taken

Set .ini settings appropriately for the Word document functionality, including the Example.doc.

[ DOC MERGE ]

● MERGE = YES
● MERGEDOCPATH = \\ATXADTDEVSRV\JHA\SADSWORD

The folder structure must be set up accordingly for Maintenance/Customer/NOA:

 

 

Consider the following scenarios when choosing settings.

● If the .ini settings are set correctly, and the folder directory exists with the example document,
the Word version generates over the WKFS version.

● If the .ini settings are set correctly, and the folder directory exists without the example
document, the WKFS version generates.

● If the MERGE setting is set to YES, but the MERGEDOCPATH is not set correctly, the WKFS
version generates.

● If the MERGE setting is set to NO or blank, but the MERGEDOCPATH is set correctly, the
WKFS version generates.

Documents are always in PDF format.
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ArgoKeys Application Elements

Service Dictionary Search Canonical Value Info Elements
Message Element Name CanocValDetail CanocValTxt

PltfmAppAdd PltfmActnType Action Type Canonical Values:

● Origination Only - Orgin and
Blank

● Fulfillment Only - LoanAcct,
GenDocs, and LoadCust

PltfmAppAdd PurpCode Host Code SilverLake Host Code for Purpose

PltfmAppAdd PurpCode Customer Type Personal or Business

PltfmAppAdd PurpCode HMDA
Reportable

True or False

PltfmAppAdd PurpCode HMDA Purpose Text from ArgoKeys Purpose Editor

PltfmAppAdd PurpCode Bridge Loan True or False

PltfmAppAdd PurpCode Improvement or
Renovation of
Dwelling

True or False

PltfmAppAdd PurpCode Use of Funds True or False

PltfmAppAdd CollatCode Collateral View
Code

ArgoKeys Collateral View code from
the collateral view editor.

PltfmAppAdd CollatCode Host Code SilverLake Host Code for collateral
type.

PltfmAppAdd CollatCode Other Collateral
Type

The ArgoKeys integration to WKFS
forms allows the user to enter the
WKFS collateral type into this field if
the user has selected a collateral
view of Other from the ArgoKeys
system.

PltfmAppAdd UserDefTxt User Defined This field maps back to the User
Defined details in the host for
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Message Element Name CanocValDetail CanocValTxt

deposit and time deposits. It is
applicable for Customer or Account.

PltfmAppAdd UserDefTxt User Defined Application

PltfmAppAdd UserDefTxt User Defined Field Name

PltfmAppAdd UserDefTxt User Defined Field Order

PltfmAppAdd UserDefTxt User Defined New Account Entry – True or False

PltfmAppAdd UserDefTxt User Defined Field Length

PltfmAppAdd UserDefTxt User Defined Field Order

PltfmAppAdd UserDefTxt User Defined Field Description

PltfmAppAdd UserDefTxt User Defined New Account Entry

PltfmAppAdd UserDefTxt User Defined Number of Decimals

PltfmAppAdd UserDefTxt User Defined Edit Code

PltfmAppAdd UserDefTxt User Defined Default Value

PltfmAppAdd UserDefTxt User Defined Custom field 1

LIT – Field Order

PltfmAppAdd AcctId Host Account
Number
Generation

YES – Host will generate Account
Number

NO – Host will not generate Account
Number

SAV – Host will generate Account
number

PltfmAppAdd ODPrvlgOptVal Allows an
account to be
overdrafted

True or False

PltfmProdSrch BrCode RegionCode 3 Character Region Code that the
branch in the BrCode element
belongs to.

PltfmProdSrch PltfmCatCode PltfmCustType PER – Personal

BUS - Business
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Message Element Name CanocValDetail CanocValTxt

PltfmProdSrch PltfmCatCode RegionCode 3 Character Region Code that the
branch in the BrCode element
belongs to.

Platform Product Inquiry - PltfmProdInq
Element Description Canonical Values

AlwRateLockType Allow rate locking on a loan
product.

True

False

BrCode Branch Code 3 Character Branch Code

BrDesc The description of the office
associated with a Branch
Code.

CatCode The code that describes a
grouping of products being
offered. This may be
promotional or marketing
related.

The Category Code from
CBRM in ArgoKeys.

CatDesc Category selected on the
General Info tab in Product
Manager.

CollatCode Collateral Host Code

CollatDesc Collateral Description

CustProfCode Customer Profit Code

CustProfDesc Profit Code Description

CustType Customer Type

This filter only filters Category
Codes.

PER

BUS

DestProdCode Host Code

FeeAmt Fee Amount

FeeCode Fee Code
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Element Description Canonical Values

FeeDesc Fee Description

InitIntRate Initial Interest Rate

InitIntRateTerm Initial Interest Rate Term (count)

InitIntRateTermUnits Initial Interest Rate Term Units Weekly

Bi-Weekly

Semi-Monthly

Monthly

Quarterly

Semi-Annual

Annual

IntBasis Interest Basis description

IntBasisDesc

IntTerm Number of units Deposit

IntTermUnits Deposit

Days

Months

IntTruncArray The available check return
method.

Image

Return

Truncate

Truncate & Image

LifeTimeCapRate Lifetime Ceiling Research

LnCapBasisType Basis for Lifetime Cap Research

LnRegArray Loan Acts

LnTraitType Initial Rate Offer

Auto Pay Offer

Real Estate

Direct

True

False
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Element Description Canonical Values

Revolving

Construction Only

Construction Perm

HELOC

Escrow

ARM

Credit Life

Risk Management

Credit Bureau

Prepaid Odd Day Interest

ARM Convertible

MaxAmt Maximum deposit amount

MaxIntRate Maximum interest rate

MinAmt The minimum amount to open a
checking account.

MinAmt The minimum amount to open a
savings account.

MinIntRate Minimum interest rate.

MktgMsg Marketing messages.

PeriodCapBasisType Periodic cap.

PeriodCapDown Periodic cap decrease. High

Low

PeriodCapUp Periodic cap increase. High

Low

PlnType HSA

PltfmAcctTypeCode The type of account being
originated.

Loan

Deposit
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Element Description Canonical Values

PltfmClsfPrimType Types of Platform Products
offered.

CDA = Certificate of Deposit

DDA = Checking/Money Mkt

IRA = Individual Retirement
Account

ILA = Installment Loan

LTC = Letter of Credit

LOC = Line of Credit

TDA = Savings

SBA = Safe Deposit Box

PltfmProdCode Product Code - The code that
identifies a Product Type of an
account within an application.

PltfmProdDesc The Production Description of
the type of account on the
General Info tab in Product
Manager.

PmtCodeArray Payment options available Installment

Single Payment

Interest Only

Principal Plus

Balloon

Irregular Payment

PmtRoundMthd Payment Round Methods D = Down

U = Up

N = To the Nearest

PmtRoundToPct Payment round to percent. .01

1.00

5.00

10.00
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Element Description Canonical Values

25.00

50.00

100.00

ProdCompareCode Product compare code.

ProdCompareDesc The description from the
Comparison tab in Product
Manager.

ProdEffDt Product effective date.

ProdExpDt Product expiration date.

ProdImg Product image (image
associated with a product).

ProdImgFormat Hard coded to BMP.

ProdSvcOptCode The Service option check
boxes from deposit products.

ProdSvcOptDesc Product service option
description

PrstHTML

PurpCode Purpose Code

PurpDesc Purpose Description

RateCeil Lifetime Ceiling

RateChgDt Rate Change Date

RateFlr Lifetime Floor

RateRoundMthd Rate Round Method

RateRoundToPct Rate Round to Percent .01

1.00

5.00

10.00

25.00

50.00
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Element Description Canonical Values

100.00

RateType Types of interest rates. Fix = Fixed

Vrbl = Variable

Adj = Adjustable

RegionCode The code that identifies a
financial institution's region that
would encompass a group of
branches.

RegionDesc The defaulted Region on the
General Info tab in Product
Manager.

Platform Document Inquiry - PltfmDocInq

Element Description Canonical Values

Required (Rq-
Request/Rs-
Response)

DocId Document name or
number or other identifying
value.

OFI - Can be any
identifying value except
XXDNFCR0.

Notice of Action - DocId
must be XXDNFCR0.

PltfmDocDlvryCode Identifier that determines
how documents are
accessed by the consumer.

eSign

OFI

UNC

Y (Rq and Rs)

PltfmDocLoc Identifier for the name or
location of requested
platform documents. It may

N/A Y (Rs)
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Element Description Canonical Values

Required (Rq-
Request/Rs-
Response)

be an eSign URL or a UNC
path.

PltfmDocStatId Identifier used to find the
status of a statement or
other document request.

Y (Rs)

PltfmId Platform Record Identifier
that can be used for other
services.

OFI - Valid PltfmId from
the database is required.

Notice of Action - PltfmId
must be blank.

N (Rq and Rs)

TrnRcptId Unique ID used to identify
specific customer
verification response.

OFI - TrnRcptId must be
blank.

Notice of Action - Valid
TrnRcptId from the
database is required.

true

false

N

Platform Document Status Inquiry - PltfmDocStatInq

Element Description Canonical Values

Required (Rq-
Request/Rs-
Response)

PltfmDocStatId Identifier used to find the
status of a statement or
other document request.

Y (Rq and Rs)

DocRqStat The statement or other
document request status.

● Wait - Waiting
● Proc - Processing
● Cmplt - Complete

Y (Rq)
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Element Description Canonical Values

Required (Rq-
Request/Rs-
Response)

● Err - Error

DocRqStatCmnt A comment related to the
status of the statement or
other document request.

N (Rs)

PltfmDocDlvryCode Identifier that determines
how the consumer
accesses documents.

eSign

OFI

UNC

Y (Rs)

PltfmDocLoc Identifier for the name or
location of requested
platform documents. It may
be an eSign URL or a UNC
path.

N/A Y (Rs)

Platform Entity Validate - PltfmEntityValidate
Element Description Canonical Values Required

ProviderCode Provider or vendor.

The only vendor currently supported is
ChexSystems.

CHK N

RegionCode Three-digit region code. N

BrCode Three-digit branch code. N

QualiFile®
Yes

No

N

StrategyCode N

StrategyDesc N

TrnRcptId Transaction receipt number. N

BirthDt Birth date. N

TaxId Tax ID. N
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Element Description Canonical Values Required

IdStateNum ID number. N

IdStateCode State that issued the IdStateNum. N

IdType ID type. N

LastName Either ComName is required, or both
FirstName and LastName are required.

N

FirstName Either ComName is required, or both
FirstName and LastName are required.

N

MiddleName Middle name. N

ComName Either ComName is required, or both
FirstName and LastName are required.

N

StreetAddr1 Street address 1 is required. Y

StreetAddr2 Second line of street address. N

City City is required. Y

StateCode State code is required for domestic
address.

N

PostalCode Postal code is required for domestic
address.

Two-character
length.

N

Cntry Country name is required for foreign
address.

Numeric value 5–9
characters in length.

N

FornAddr Foreign address. true

false

N

PhoneNum Phone number. N

Platform Product Search - PltfmProdSrch
Element Description Canonical Values

BrCode Branch Code

CollatCode This code is bank-defined and
is used to define the type of
collateral used to secure the
loan.

Titled Vehicle

Real Estate

Unsecured
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Element Description Canonical Values

Certificate of Deposit

Savings/Checking

CollatDesc Selected Collateral Types on
the Collateral tab in Product
Manager.

LnTraitType Elements describing the
multitude of characteristics that
help define a loan product.

● Loan:

○ Direct
○ Real Estate (RE)
○ ConstOnly=Construction only
○ ConstPerm=Construction to

Perm
○ AutoPayOffer

● LOC:

○ Revol
○ HELOC

OpenCeilAmt Maximum loan amount.

OpenFlrAmt Minimum amount to open a
deposit and loan account.

PlnType Tax Plan types as approved by
the IRS.

HSA: HSA = Yes

Null/blank = Non-HSA

PltfmAcctTypeCode Type of Account being
originated.

Loan

Deposit

PltfmCatCode The code that describes a
grouping of products being
offered. It may be promotional
or marketing related.

PltfmCatDesc The Category selected on the
General Info tab in Product
Manager.

PltfmClsfPrimType Types of Platform Products
offered.

CDA = Certificate of Deposit
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Element Description Canonical Values

DDA = Checking/Money Mkt

IRA = Individual Retirement Account

ILA = Installment Loan

LTC = Letter of Credit

LOC = Line of Credit

TDA = Savings

SBA = Safe Deposit Box

PltfmClsfSecdType Elements further identifying the
type of Loan or Deposit
instrument being searched for.

● DDA:

○ N = Now
○ M = Money Market
○ C = Interest Checking
○ I = Non-Interest Bearing

● TDA:

○ Not Y = Regular Savings
coded as R=Regular

○ Y = Club Account coded as
X=Club

● Loan:

○ S = Secured
○ U = Unsecured

PltfmCustType Identifies the type of Customer. PER = Personal

BUS = Business

PltfmProdDesc Production Description of the
type of account on the General
Info tab in Product Manager.

PmtCode Payment Type I - Installment

T - Interest Only

B - Balloon

S - Single Payment

P - Principal Plus

ArgoKeys jXchange User Guide 60 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Element Description Canonical Values

R - Irregular

ProdTermCeil Integer length of the term.

ProdTermFlr Integer length of the term.

ProdTermUnits ● Deposits:

○ Months
○ Days

● Loans:

○ Months only

PurpCode This code is bank-defined and
is used to define the purpose of
the loan.

PurpDesc Selected Purpose Description
on the Purpose tab in Product
Manager.

RateIdxDesc Rate Index Description - Used
to map index selected in the
case of no Risk Based Pricing
Index setup. If Risk Based
Pricing is enabled, then the
system will take that index.

RateType Types of Interest rates. Loans

Fix = Fixed

Vrbl = Variable

Adj = Adjustable

RegionCode The code that identifies a
financial institution's region that
could encompass a group of
branches.

RegionDesc The defaulted Region on the
General Info tab in Product
Manager.
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To Create a New Customer
The following requirements must be met to create a new customer:

● PltfmAppActnType must be set with LoanCust.
● Validation only occurs on new customers when CustId is null.
● Relationship and ownership validation occurs at the customer account level and are skipped

when PltfmAppActnType = LoadCust.
● CustId is required for PltfmAppActnType when using GenDocs or LoadAcct.

NOTE
These settings dictate if hard errors are thrown before soft errors. For example, if Officer
Code is invalid and Tax Id exists, it is likely the hard error returns and not the soft error for
the same customer on a single request.

● CustClsfCode is required from PltfmAppActnType when using LoadCust.
● OffCode is required if OffRmk is present and vice versa.
● OffCode is required and OffRmk is required if record is present. No other record is required

other than a primary, but the OffInfoArray object cannot be partially filled.
● Privacy Act Opt Out (Reg E) is mapped based on default value from the CIF Default

Parameter File.

Existing customer validation, including WARNCIF validation, only occurs during GenDocs or
LoadAcct. All CIFs return in CustIdArray (regardless if they are new or not) in the same order
as PltfmAppCustArray. KeysServices validation errors are sent first for all customers. If
passed on KeysServices validation, then all host errors are sent. Host errors do not map
ErrElem, ErrLoc, or ErrElemVal and do not reference customer name.

Deposit Platform App Add - PltfmAppAdd
Deposit fields that are not required have not been mapped, except for user-defined fields, and
are not included in the following table.

Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

AcctClsfCode Account classification code.

The classification code for an
account.

SilverLake
Parms

N Y Y

AcctID Account number. N N Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

AcctLvlSecCode The code that references account
level special handling security
processes/accesses.

A = All
access

B = Balance
only

E =
Existence
only

N = No
access

N N Y

AcctOwnType Account ownership type. Ind =
Personal

Bus =
Business

Y Y Y

AcctTitle Customer and additional names
in the Account Titling section of
the cover tab of the ArgoKeys
New Account Setup.

AcctTitle mimics traditional
ArgoKeys by populating with up
to three lines of account titling
information.

Element is a part of the
AcctTitleArray.

N N N

AcctType Host account type. D – Savings

S – Savings

T –
Certificate of
Deposits

X – Club
Savings

I - IRA

N Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

AgentTitle Agent title. N N N

BrCode Branch code. Office Editor Y Y Y

CallRptCode Call report code.

Must be a valid canonical value.

SilverLake
Parms

N N Y

City City.

ClubPln Plan type for savings club
account.

Default retrieved from the host.

Valid canonical values are 0–9.
These values are validated only
for deposit accounts that have a
product primary type of TDA and
secondary type X.

SilverLake
Parms

C C Y

CntryType Country.

CommAuthCode Authorization code for the agent.
Required if a CommAuthTypeRec
is received.

1–13 N N Y

CommAuthType Authorization type for the agent.
Required if a
CommAuthTypeRec is received
in the CommAuthArray.

Basic =
Basic
powers

Extend =
Extended
powers

N N Y

ComName Name of the person opening the
account. ComName is located in
the EstbPersonName complex. It
is required for a business
account.

N N Y

CRACenTract Census Tract - Census Tract
information for Community
Reinvestment Act reporting.

N N N
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

CRACountyCode County code. N N N

CRALoc The code designates where the
loan was originated.

N N N

CRASMSACode Standard metropolitan statistical
area.

N N N

CRAStateCode State code. N N N

DormantChgWav Dormant charge waive.

Indicates whether or not an
account is charged the regular
service charge if it enters
dormant/escheat status.

If the DormantChgWav = Chg,
then the ArgoKeys Service
Charge Type drop-down list
selects Chg Dormant/Escheat
Only or else map SerChgWav.

This element is used in
conjunction with SerChgWav to
determine the charge/waive type.
If the field is populated with Wav,
then SerChgWav must be blank or
not be present.

The DormantChgWav field
corresponds to the ChgDormant/
Escheat Only selection item in the
Type drop-down list within the
Service Charge Information group
box on the Additional Info tab.

Defaults are set based on the
host setting. Applicable values
are: Chg, Wav, or blank.

Wav N C Y

DueDilgntCmpltArray Provides the user with the ability
to indicate what due diligence has
been performed.

N N Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

XSYN1.Ini and client ini settings
required: CUSTVERIFICATION
section YHBSA="SEC" or
YHBSA="HOSTREQ".

DueDilgntCmpltType The action reported was
completed in the
DueDilgntCmpltArray.

True

False

N N Y

EstbPersonTitle Title of the person opening the
account. Required for a business
account.

N N Y

FedWithCode Federal tax withholding code. SilverLake
Parms

N Y Y

FornAddr Beneficiary foreign address
indicator.

If foreign address, then map
country code only.

If non-foreign address, map state
and postal code only.

IntCycle Interest cycle. SilverLake
Parms

N N Y

IntDisp This code designates the
disposition of interest. (Interest
Rate Information).

Applicable only to interest-bearing
accounts.

Required for fulfillment if account
is interest-bearing based on
SilverLake service charge type
associated to the ArgoKeys
product defined as interest-
bearing.

A =
AddBackToA
cct

C =
PayByChk

D =
DepToAcct

N C Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

IntDisp is no longer required for
interest-bearing account requests
submitted solely for origination
(when the PltfmActnType value
is Orgin or Blank). However, if
IntDisp is present, it must contain
a valid value. It is still required for
interest-bearing account requests
submitted for fulfillment (when the
PltfmActnType value is LoadAcct
or GenDocs). Validation of the
other interest fields still occurs as
usual in origination validation, as
those fields are conditioned on
other factors.

IntDispAcctId Required field when the IntDisp =
DepToAcct.

C C Y

IntDispAcctType Required field when the IntDisp =
DepToAcct and must be a valid
canonical.

D =
Checking/
Money Mkt

S = Savings

C C Y

IRSExmpCode The exemption code as defined
by the IRS.

Field is applicable for non-
individual accounts and is for
documentation purposes only.

Must be a valid canonical value.

SilverLake
Parms

N N Y

ItmTrunc Item truncation/safekeeping.

Required for fulfillment when
using PltfmActnType LoadAcct,
but not GenDocs.

Trunc – Yes/
Truncate

NoTrunc –
No/Return

N Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

Img –
Image/
Image

ImgAndTrun
c – Both/
Truncate &
Image

ODPrvlgOptInfoArray Overdraft privilege option
information array.

Deposit Only Y Y Y

ODPrvlgOptInfoRec Deposit only. Only one
occurrence.

Y Y Y

ODPrvlgOptVal If the product is not configured to
display Card Opt-In, the
appropriate default value must be
established in the NSF/OD
Parameters section of the
SilverLake Service Charge Type
Parameters to avoid a host error
at account fulfillment.

If the product is not configured to
display the Card Opt-In selection,
the element’s value is ignored.

Deposit only.

Accept =
Accept opt-
in

Decline =
Declined

Inelgb =
Ineligible

Exmp =
Exempt

NoRs =
Failed to
Respond

Y Y Y

OffCode Officer Code in OffInfoArray.
Primary required PRI.

SilverLake
Parms

N Y Y

OffInfoArray Officer array containing the
officers assigned to the account
and their respective roles.

Primary officer PRI is required.
Each entry of OffInfoRec in the
OffInfoArray must contain a

Dom N Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

valid OffCode value and a valid
OffRmk value.

Also, an OffRmk must not be
duplicated within the array.

OffRmk Officer Code in OffInfoArray. CBRM >
General
Description
Editor >
Common >
Banker
Role

N Y Y

PltfmClsfPrimType Platform Classification Primary
Type - Elements further
identifying the type of loan or
deposit products being searched
for.

Example: If Loan is selected as
PltfmAcctTypeCode:

● Mortgage
● Auto
● Commercial
● Ag
● Equipment

If Deposit is selected as
PltfmAcctTypeCode, then:

● Checking
● Money Market
● Savings
● CD

CDA =
Certificate of
Deposit

DDA =
Checking/
Money Mtk

IRA =
Individual
Retirement
Account

ILA =
Installment
Loan

LTC = Letter
of Credit

LOC = Line
of Credit

TDA =
Savings

SBA = Safe
Deposit Box

Y Y Y

PltfmOwnCode Platform owner code. Y Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

The code that describes the
ownership of an account from a
platform perspective.

PODRegType Account is subject to the non
probate payable on death statute
transfer.

True Condition:

Applicable to the state on
Missouri (MO) and if there is an
account relationship for a
CodeOwner of JAW, JWS, IND,
or OTH for a deposit account type
of Reg and customer type of P
and a CodeRel of POD, else
false.

JAS - Joint - Tenants in common
without svrshp

JWS - Joint - With survivorship

IND - Individual

OTH - Other

True

False

N C Y

PostalCode ZIP code.

PrimeRateIdx Override interest rate number.

Master rate number (override
rate).

Must be a valid canonical if
present.

If the selected, branch and
master rate are both configured
for a matching SilverLake region,
the region configured master rate
is used; else, the selected master

SilverLake
Parms

N N Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

rate without region configuration
is used.

PrimSrcFundsType Source of funds used to open an
account is Primary.

Only one occurrence of
PrimSrcFundsType = True is
allowed.

Primary =
True

Not primary
= False

Y Y Y

ProdCode Product Code - The code that
identifies a Product Type of an
account within an application.

Y Y Y

ProdSvcOptArray Array of service options available
for the product.

ChkOrder –
Check Order

ATM – ATM/
Debit Card

OLBANK –
Internet/
Online
Banking

REWARD –
Rewards

SWEEP –
Sweep
Arrangemen
t (Overdraft
Protection)

STMTOPT –
Statement
Options (In
Addition to
Primary
Statement)

AFT –
Funds

N N/A N/A
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

Transfer/AF
T

PrvdNameCode Provider name for
DueDilgntCmpltArray.

YHBSA -
Yellow
Hammer
BSA

N N Y

RateCeil Rate ceiling.

Applicable for interest-bearing
accounts only.

Floor cannot be higher than the
ceiling if both are present.

N N N

RateFlr Rate floor.

Applicable for interest-bearing
accounts only.

Floor cannot be higher than the
ceiling if both are present.

N N N

RateRevDt Rate review date.

Applicable for interest-bearing
accounts only.

N N Y

RateRevTerm Rate review term.

Applicable for interest-bearing
accounts only.

N N N

RateRevTermUnits Rate review term units.

Applicable for interest-bearing
accounts only.

Required if RateRevTerm is
present and greater than 0, and
must be a valid canonical.

Days

Months

N N Y

RateVar Rate variance percent. N N N
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

Applicable for interest-bearing
accounts only.

RateVarCode Rate variance code (+ or -).

Applicable for interest-bearing
accounts only.

Required if RateVar is present
and greater than 0, and must be a
valid canonical value.

Above (+)

Below (-)

N N Y

RegionCode The code that identifies a
financial institution's region that
would encompass a group of
branches.

Region
Editor

Y Y Y

SalesPerson Sales person. N N Y

ScsrCstdnName The designated successor
custodian for an UGMA or UTMA
account.

N N N

SerChgCycle Service charge cycle. SilverLake
Parms

N N Y

SerChgWav Service charge waive.

If SerChgWav = Chg, then
ArgoKeys Service Charge Type
selects Charge.

If SerChgWav = Wav, then
ArgoKeys Service Charge Type
selects Waive. If value is Wav or
Chg, then DormantChgWav
must be blank or absent.

SerChgWav corresponds to the
Charge and Waive selection
items in the Type drop-down list
within the Service Charge
Information group box on the

SilverLake
PARMS

N C Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

Additional Info tab. Used in
conjunction with
DormantChgWav to determine
the charge/waive type.

Defaults are set based on the
host setting. Applicable values
are: Chg, Wav, or blank.

SerChgWavExpDt Waive reason expiration date. Date N N Y

SerChgWavRsnCode Waive reason code. N N Y

SigNumCnt Number of signatures required for
withdrawal.

Field is validated when the
Number of Signatures Required
for Withdrawal field is greater
than or equal to 1 or less than or
equal to 9.

In traditional ArgoKeys CBRM
Region Config, bank
administrators can configure
whether to specify a default
value, supply the default value,
and determine whether users can
change the default value during
new account setup if a default
value is supplied.

This configuration can be made
for personal deposit, business
deposit, personal time deposit,
business time deposit, personal
SBA, and business SBA account
types.

The SigNumCnt element in the
CommAuthArray does not allow
more than 99 signatures for
deposit and time deposit business

1–9 Forms
only

N N Y
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

account fulfillment (LoanAcct
and GenDocs).

SrcFundsAmt Source funds amount.

Amount of the source of funds
used to open an account.

Deposit only.

Y Y Y

SrcFundsArray Source of funds array.

Array of items related to source of
funds used to open an account.

Y Y Y

SrcFundsCode Source funds code.

Represents the account opening
source of funds.

A duplicate SrcFundsCode is not
allowed.

Source of
Fund Editor
Item Code

Y Y Y

SrcFundsInfo Source of funds information. Y Y Y

StateCode State.

StmtCycle Statement cycle. SilverLake
Parms

N N Y

StmtPasCode Statement passbook code for
savings accounts.

Supported for deposits only.

Required for savings (TDA)
accounts only.

If the account is not a savings
product, the element is ignored.

Default value is Stmt.

Stmt -
Statement

Pas -
Passbook

N Y Y

StreetAddr1 Street address.

StreetAddr2 Second line of the street address.
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Element Name Description
Applicable
Values

Req
Org

Req
Ful Val*

UserDefCode Codes that can be defined by the
financial institution.

DD elements are returned in the
service dictionary for deposits.

<CanocValTxt>DD</
CanocValTxt>

N/A N/A N/A

UserDefTxt True

False

N/A N/A N/A

*Values for these columns are:

● Req Org = Required for origination
● Req Ful = Required for fulfillment
● Val = Validation
● Y = Yes
● N = No
● C = Conditionally required

Time Deposit Platform App Add - PltfmAppAdd
Time deposit fields that are not required have not been mapped, except for user-defined fields,
and are not included in the following table.

Element Name Description
Applicable
Values

Req
Org

Req
Full Val

AcctClsfCode Account classification code. N Y

AcctId The account ID for the deposit
type.

N N

AcctLvlSecCode The code that references
account level special handling
security processes/accesses.

A = All
access

B = Balance
only

N N Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

E =
Existence
only

N = No
access

AcctOwnType Account ownership type. Personal =
Ind

Business =
Bus

Y Y Y

AcctTitle Customer and additional
names in the Account Titling
section of the cover tab of the
ArgoKeys New Account Setup.

AcctTitle mimics traditional
ArgoKeys by populating with up
to three lines of account titling
information.

Element is a part of the
AcctTitleArray.

N N N

AcctType The account type of the
account created.

N N

ACHCrAcctID ACH account ID. N N

ACHCrName Required if IntDisp =
PaybyACH.

ACHCrtRtNum ACH routing number.

Required if IntDisp =
PaybyACh.

Numeric
only

C C

ACHTrnCode ACH tran code.

Required if IntDisp =
PaybyACH.

D =
Checking/
Money Mkt

S = Savings

C C Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

AgentTitle Agent title. N N N

AutoRenType Instrument renews
automatically at maturity.

True

False

N Y

BrCode Branch code. Office Editor Y Y Y

CallRptCode Call report code.

Must be a valid canonical
value.

SilverLake
CDPAR

N N Y

CDTerm Certificate of deposit term. N Y Y

CDTermUnits Certificate of deposit term units. Days

Months

N Y Y

City City.

CntryType Country.

CommAuthCode Authorization code for the
agent. Required if we receive a
CommAuthTypeRec.

1–13 N N Y

CommAuthType Authorization type for the
agent. Account segment
required if a
CommAuthTypeRec is
received in the
CommAuthArray.

Basic =
Basic
powers

Extend =
Extended
powers

N N Y

ComName Name of the person opening
the account located in the
EstbPersonName complex.
Required for a business
account.

N N Y

CRACenTract Census tract. N N N

ArgoKeys jXchange User Guide 78 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Element Name Description
Applicable
Values

Req
Org

Req
Full Val

Census tract information for
community reinvestment act
reporting.

CRACountyCode County code. N N N

CRALoc The code designates where the
loan was originated.

N N N

CRASMSACode Standard metropolitan
statistical area.

N N N

CRAStateCode State code. N N N

EstbPersonTitle Title of the person opening the
account. Required for a
business account.

N N Y

FedWithCode Tax plan federal withholding
code.

SilverLake N Y Y

FornAddr Beneficiary foreign address
indicator.

IntCalcCode Interest calculation method. S - Simple

C -
Compound

N Y

IntDayMonth The day of the month on which
interest payments should
always be generated.

This optional element
determines the day of the
month in which interest should
be paid when the first payment
date has a day value in the
range 28–31.

28

29

30

31

N N Y

IntDisp Disposition of interest.

IntDisp is no longer required
for interest-bearing account

AddBackTo
Acct - Add
Back to
Account

N Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

requests submitted solely for
origination (when the
PltfmActnType value is Orgin
or Blank). However, if IntDisp
is present, it must contain a
valid value. It is still required for
interest-bearing account
requests submitted for
fulfillment (when the
PltfmActnType value is
LoadAcct or GenDocs).
Validation of the other interest
fields still occurs as usual in
origination validation, as those
fields are conditioned on other
factors.

IntDisp returns a default value
if one is setup in CDPAR-Time
Deposit Type Code
maintenance for branch,
region, or neither.

PayByChk -
Pay By
Check

DepToAcct-
Deposit to
Account

PayByACH -
Automated
Clearing
House

IntDispAcctType Interest disposition account
type.

Required only if IntDisp is D -
Deposit.

D -
Checking/
Money Mkt

S - Savings

C C N

IntPmtStrtDt Interest payment start date. N N

IntRate Interest rate. Y Y

IntTerm Interest term. N Y

IntTermUnits Interest term units. Days

Months

N Y Y

IntYrBaseCode The code for the year base. 0–365

2–360

N Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

IRSExmpCode The exemption code as defined
by the IRS.

Field is applicable for non-
individual accounts and is for
documentation purposes only.

Must be a valid canonical
value.

Applicable only if
FedWithCode value is Do Not
Withhold.

SilverLake
Parms

N N Y

MatDt Maturity date. N N Y

OffCode Officer code in OffInfoArray.

Primary required PRI.

SilverLake N Y

PenCode Code that references the
penalty for early withdrawals of
a deposit instrument.

SilverLake N N Y

PlnCode From SilverLake menu IRAPAR
option Plan Types (option #2).

Applicable for IRAs only.

N N Y

PlnCvrgType Valid for HSAs only. N N N

PlnFeeCode Plan fee code.

Applicable for IRAs only.

Y = Charge
Fee

N = No
Charge

C =
Customer
Paid

C C Y

PltfmClsfPrimType Platform classification primary
type.

CDA =
Certificate of
Deposit

Y Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

Elements further identifying the
type of loan or deposit products
being searched for.

Example: If Loan is selected as
PltfmAcctTypeCode, then:

● Mortgage
● Auto
● Commercial
● Ag
● Equipment

Example: If Deposit is selected
as PltfmAcctTypeCode, then:

● Checking
● Money Market
● Savings
● CD

DDA =
Checking/
Money Mkt

IRA =
Individual
Retirement
Account

ILA =
Installment
Loan

LTC = Letter
of Credit

LOC = Line
of Credit

TDA =
Savings

SBA = Safe
Deposit Box

PltfmOwnCode Platform owner code.

The code that describes the
ownership of an account from a
platform perspective.

Y Y Y

PODRegType Account is subject to the non
probate payable on death
statute transfer.

True Condition:

Applicable to the state on
Missouri (MO) and if there is an
account relationship for a
CodeOwner of JAW, JWS,
IND, or OTH for a deposit
account type of Reg and

True

False

N C Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

customer type of P and a
CodeRel of POD, else false.

PostalCode ZIP code.

PrimeRateIdx Override interest rate number.

If a rate number
(PrimeRateIdx) is present, it
must be a valid canonical.

SilverLake C C Y

PrimSrcFundsType Primary source of funds type.

Source of funds used to open
an account is Primary.

Primary =
True

Not primary
= False

Y Y Y

ProdCode Product code.

The code that identifies a
Product Type of an account
within an application.

Y Y Y

RateCeil Rate ceiling.

Applicable for interest bearing
accounts only.

Floor cannot be higher than the
ceiling if both are present.

N N N

RateFlr Rate floor.

Applicable for interest bearing
accounts only.

Floor cannot be higher than the
ceiling if both are present.

Cannot be less than zero.

N N N

RateRevDt Rate review date. Date N N N
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

Applicable for interest bearing
accounts only.

RateRevTerm Rate review term.

Applicable for interest bearing
accounts only.

N N N

RateRevTermUnits Rate review term units.

If a rate review term is present,
a rate review term unit must be
present and must be a valid
canonical value.

Day

Month

N N

RateType Rate type. Fix

Vrbl

N N

RateVar Rate variance percent.

Applicable for interest bearing
accounts only.

N N N

RateVarCode Rate variance code.

If a rate variance greater than
zero is present, a rate variance
code must be present and must
be a valid canonical.

Positive

Negative

N N

RegionCode The code that identifies a
financial institution's region that
would encompass a group of
branches.

Region
Editor

Y Y Y

SalesAssociate Sales associate. N N

SalesPerson Sales person. N N Y

ScsrCstdnName The designated successor
custodian for an UGMA or
UTMA account.

N N N
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

SigNumCnt Number of signatures required
for withdrawal.

Field is validated when the
Number of Signatures
Required for Withdrawal field
is greater than or equal to 1 or
less than or equal to 9.

In traditional ArgoKeys CBRM
Region Config, bank
administrators can configure
whether to specify a default
value, supply the default value,
and determine whether users
can change the default value
during new account setup if a
default value is supplied.

This configuration can be made
for personal deposit, business
deposit, personal time deposit,
business time deposit, personal
SBA, and business SBA
account types.

The SigNumCnt element in the
CommAuthArray does not allow
more than 99 signatures for
deposit and time deposit
business account fulfillment
(LoanAcct and GenDocs).

N N Y

SoleSpousDistCode Sole spousal distribution code.

Applicable for IRAs only.

True

False

C C Y

SpousPlnCode Spousal plan code.

Applicable for IRAs only.

True

False

C C Y

SrcFundsAmt Source of funds amount. Y Y Y
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

Amount of the source of funds
used to open an account.

SrcFundsArray Source of funds array.

Array of items related to the
Source of Funds used to open
an account.

Y Y Y

SrcFundsCode Source of funds code.

A code that represents the
source of funds for credit
transactions and the outgoing
source for debit transactions.

Source of
Funds Editor
Item Code

Y Y Y

StateCode State.

StmtFreqCode Statement frequency code. N - No

Statement

M - Monthly

Q -
Quarterly

S - Semi-
annually

A - Annually

Y Y Y

StreetAddr1 Street address.

StreetAddr2 Second line of the street
address.

UserDefCode Codes that can be defined by
the financial institution.

TD elements are returned in
the service dictionary for time
deposits.

N N N
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Element Name Description
Applicable
Values

Req
Org

Req
Full Val

<CanocValTxt>TD</
CanocValTxt>

UserDefTxt N N N

Deposit and Time Deposit Customer Segment
All of the following listed fields for Platform App Add Deposit and Time Deposit Customer
Segment have been mapped. However, not all are required. The required fields have Y in the
Required column.

Element Name Description Applicable Values
Req
Org

Req
Ful Val

AcctRelCode Borrower

Co-borrower

Co-signer

Guarantor

N N Y

AddrCat2Use Business rule: Only
one, either
AddrCatUse or
AddrCat2Use, can
have a value.

IRS=Internal Revenue
Service (one
maximum)

Phys=Physical
(required, one
maximum)

C C Y

AddrCatUse Business rule: Only
one, either
AddrCatUse or
AddrCat2Use, can
have a value.

Cust = Mailing (one
maximum)

C C Y

AddrInfo Y Y Y

AlienResident Is the applicant a
permanent resident
alien?

True

False

C C Y

ArgoKeys jXchange User Guide 87 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Element Name Description Applicable Values
Req
Org

Req
Ful Val

Only applicable if
TinCode is IRS
Reportable:

S – Alien Business

C – Canadian
Reportable

G – Foreign Non-
Reportable

F – Foreign Reportable

D – ITIN Foreign Tax
ID

AlienW8Type The type that identifies
the IRS classification
that grants a foreigner
an exemption from
certain U.S.
information return
reporting and backup
withholding
regulations.

Only applicable if
AlienResident = True.

BEN - Beneficiary
Owner

ECI - Effectively
Connected Income

EXP - US Tax
Withholding

IMY - Intermediary

BEN-E - W8BEN-E

C C Y

BenflOwnExclCode Reason for exclusion
as a FinCEN entity.
Required if
ReqLegalEntityType =
False.

SilverLake Entity
Exclusion Reason
Parameter

N N N

BirthDt Date of birth.

It is required if the
CustType is Personal.

C C Y

BrCode Branch code. Y Y Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

CertCode The code that
designates the status
of the tax identification.

C = Certified

U = Uncertified

S = Certification Sent

B = B Notice Sent

Y Y

CertCodeDt Certification code date.

It is required if the
CertCode is Certified
or Certification Notice
Sent.

N Y

City City. C C N

CntryType Country code.

Required if foreign.

C C Y

CommAgentTitle Agent title. Specifies
the title of the customer
as an agent and is only
applicable to personal
customers.

N N Y

CommAuthCode Authorization code for
the agent. Applicable
to personal customers
only.

The combination of
CommAuthType and
CommAuthCode
refers back to the
account-level
CommAuthArray to
specify which power
the agent may execute.
Required if
CommAuthTypeRec
is received.

Basic: 1–7

Extend: 1–13

N N Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

CommAuthType Authorization type for
the agent. The
combination of the
CommAuthType and
CommAuthCode
refers back to the
account-level
CommAuthArray to
specify which power
the agent may execute.
Required at customer
level if a
CommAuthTypeRec
is received in the
CommAuthArray.

NOTE
Applicable to
personal customers
only.

Basic

Extend

N N Y

ComName Business Name is
required if the
CustType is Business.

C C Y

CustClsfCode Customer class code.

CustClsfCode is
validated for valid
PltfmActnType values
of LoadCust, LoadAcct,
GenDocs, and Orign.

CustClsfCode is
required when
PltfmActnType equals
LoanCust.

Canonical values are
stored in the
SilverLake Class
Code parameter file
(JHPAR #5).

N N Y

CustId Required for action
types GenDocs and
LoadAcct only. Not

N C N
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

required for Orign or
LoadCust.

CustType Identifies the type of
customer. For
example, business or
personal.

P = Personal

B = Business

Y Y Y

EmailAddr Email address. N N N

EmailArray Array of email info. N N N

EmailInfo N N N

EmailType Only one email type is
allowed per array.

PrimaryEmail

OtherEmail

N N N

EmplName Employer name. N N N

FirstName First Name is required
if the CustType is
Personal.

C C Y

FornAddr Is this a foreign
address?

N N N

Gender Sex. Male

Female

N N N

HldMailCode Used to support
customer level
separate mailing
indicator.

True

False

N N Y

IdVerify At least one
occurrence.

Y Y Y

IdVerifyArray An array of
Identification
Verification values.

Y Y Y

IdVerifyCode The identification code
that is used to

Y Y Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

authenticate the
customer.

IdVerifyDesc The description of the
identification code that
is used to authenticate
the customer.

N N N

IdVerifyQuery A description of the
query/question that
could be used for
customer/account
identification purposes.

ExpDt = Expiration
Date

IssState = Issued By

IssLoc = Place of
Issuance

IssDt = Date Of
Issuance

ConDt = Contact Date

VerifId = Verification
Code

Y Y Y

IdVerifyQueryArray An array of
identification query/
questions and their
respective values for
customer/account
verification.

Y Y Y

IdVerifyQueryDataTyp
e

This element identifies
what type of attributes
corresponds with the
IdVerifyQueryVal
Dt.Decimal.Intger.S
tring.

N N N

IdVerifyQueryInfo Y Y Y

IdVerifyQueryVal A value that
corresponds with the
description of the
query/question

The Issue State
(IssState) must be
valid if the
MULTIDLIST setting is

Y Y Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

(IdVerifyQuery) that
could be used for the
customer/account.

"Yes" in the Distributor
section of the
XSYN1.INI file.

IdVerifyVal The identification value
that is used to
authenticate the
customer.

N Y Y

IsPrimCustRel EntityPrimType_Type
extension
+ClosedEnum_Type

N N Y

LastName Last Name is required
if the CustType is
Personal.

C C Y

MiddleName N N N

NAICSCode NAICS code. No
validation occurs.
However, if an invalid
value is sent in the field
an error will occur. It
must be a valid value.

Argo database N N Y

OccType Customer occupation. N N N

OffCode Officer code in
OffInfoArray.

PRI

OTH

N N Y

OffRmk Officer role in
OffInfoArray.

N N Y

PersonName Y

PhoneArray Array of phone info. Y Y Y

PhoneInfo At least one array of
phone information is
required.

Y Y Y

PhoneNum Phone number. C C Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

Required for new
customers only.

PhoneNumDsp Phone Number Display
- Based on format
codes which may
include special
formatting.

01 (XXX)XXX-XXXX

02 XXX-XXX-XXXX

03 XXX/XXX/XXXX

04 XXX.XXX.XXXX

05 XXX-XXX-
XXXXXXX

06 XXXXX-XXX-XXX-
XXXX

99
XXXXXXXXXXXXXX
XXXXXX

PhoneType Personal new
customers can have
any of the phone types,
but it is required to
have either
HomePhone,
HomeCell,
BusinessPhone, or
BusinessCell.

Business new
customers can have
any of the four
business phone types,
and it is required to
have either
BusinessPhone or
BusinessCell or both.
You cannot have
HomePhone,
HomePhone2,

HomePhone

HomePhone2

BusinessPhone

BusinessPhone2

HomeFax

BusinessFax

HomeCell

BusinessCell

C C Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

HomeFax, or
HomeCell.

Only one phone type is
allowed per array.

PltfmAddrArray Array of platform
application customer
addresses.

Y Y Y

PltfmAddrInfo At least one
occurrence of a
physical address is
required. Two optional
occurrences of
customer (represents a
mailing address) and
IRS addresses are
allowed.

Y Y Y

PostalCode Postal code.

Required if not foreign.

C C Y

ReqLegalEntityType Indicates whether the
customer is a FinCEN
legal entity. A setting of
ReqLegalEntityType =
True indicates
origination only. A
default message
appears. If
ReqLegalEntityType =
False, then a
BenflOwnExclCode is
required.

True

False

N N N

StateCode State code.

Required if not foreign.

N N Y

StdIndustCode SIC Code. N N N
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

StreetAddr1 Street address. C C N

StreetAddr2 Second line of the
street address.

N N N

TaxId Tax identifier.

Deposits only.

Not required or
collected if TINCode =
A or TIN Applied for.

Not required if
IRSReportable = N.

Not required if
IRSReportable = A
and ALIENREPREQ =
YES.

Required if
IRSReportable = Y
and TINCode does not
= A.

C C Y

TinCertType Customer can legally
certify the tax
identification number.

There is an .ini setting
(INI =
ADVOWNSCENRIO)
that drives the default
value. No turns off
default value off.

True

False

N N Y

TINCode The code that
designates the type of
tax identification
number.

Y Y Y

TINInfo Y Y Y
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Element Name Description Applicable Values
Req
Org

Req
Ful Val

UserDefCode Codes that can be
defined by the financial
institution.

N N N

UserDefCode Codes that can be
defined by the financial
institution.

CF elements are
returned in the service
dictionary for CIF.

<CanocValTxt>CF</
CanocValTxt>

N N N

UserDefInfoArray Array of UserDefInfo. N N N

UserDefTxt User Defined Text is
part of a matched pair
array that describes
the proceeding
elements.

N N N

Loan Platform App Add - PltfmAppAdd
All the following fields for Platform App Add Loans have been mapped. However, not all are
required. The required fields have Y in the Required column.

CoBorrower fields are the same as Borrower. Use a Customer Type of CoBorrower instead
of Borrower when searching for fields in ArgoKeys.

Platform App Add Application Loan Information

Element Name Description
Applicable
Values Required Validated

ProdCode Used by ArgoKeys in
the product match
editor to locate
ArgoKeys products.

Y Y

BrCode Y Y

RegionCode Y Y
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Element Name Description
Applicable
Values Required Validated

ProceedAmt Y Y

IntRateType F = Fixed

Vrbl = Variable

Adj = Adjustable

N N

RateIdxDesc

PmtCode The payment code
determines how the
payment is
calculated on the
loan. Valid entries
are:

I = Installment

T = Interest Only

B = Balloon

S = Single
Payment

P = Principal Plus

R = Irregular

Y Y

BallPmtAmount If the PmtCode = B
and this amount is
not zero, then the
system sends a
Payment Type of
Balloon and a
Balloon Payment
Type of Calculate
Balloon Amount.

N N

PmtTerm

LnTerm The Loan Term
consists of the Term
Count (TermCnt) and
the Term Units
(TermUnits).

IntCalcCode

FirstPmtDt N N

PurpCode Y Y
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Element Name Description
Applicable
Values Required Validated

LnRePmtSrc

RegionCode Y Y

RateType

LnAppType Application type of
the loan.

New = New

Refi = Refinance

Renew =
Renewal

RenewWithMod
= Renewal with
Modification

Mod =
Modification

Y Y

PltfmClsfPrimType Platform
Classification
Primary Type -
Elements further
identifying the type of
loan or deposit
products being
searched for.

Example: If a Loan is
selected as
PltfmAcctTypeCode
, then:

● Mortgage
● Auto
● Commercial
● Ag
● Equipment

Example: If Deposit
is selected as
PltfmAcctTypeCode
, then:

CD = Certificate
of Deposit

DDA = Checking/
Money Mkt

IRA = Individual
Retirement
Account

ILA = Installment
Loan

LTC = Letter of
Credit

LOC = Line of
Credit

TDA = Savings

SBA = Safe
Deposit Box

Y Y
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Element Name Description
Applicable
Values Required Validated

● Checking
● Money Market
● Savings
● CD

OfficeInfoArray Contains a collection
of simple elements
that contain office
information.

OfficeInfoRec

OffCodeText

OffCode

OffRmk

ProceedAmt Y Y

RateIndxDesc Used to map index
selected in the case
of no Risk Based
Pricing Index setup.
If Risk Based
Pricing is enabled,
then the system
takes that index.

N N

PmtCode The payment code
determines how the
payment is
calculated on the
loan. Valid entries
are:

I = Installment

T = Interest Only

B = Balloon

S = Single
Payment

P = Principal Plus

R = Irregular

Y Y

BallPmtAmount If the PmtCode = B
and this amount is
not zero, then the

N N

ArgoKeys jXchange User Guide 100 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Element Name Description
Applicable
Values Required Validated

system sends a
Payment Type of
Balloon and a
Balloon Payment
Type of Calculate
Balloon Amount.

LnTerm The Loan Term
consists of the Term
Count (TermCnt) and
the Term Units
(TermUnits).

TermCnt Number of Payments Months

Semimonthly

Years

Y Y

TermUnits Payment Frequency Y Y

FirstPmtDt N N

PurpCode Y Y

IntRateType F = Fixed

Vrbl = Variable

Adj = Adjustable

N N

LnAppType Application type of
the loan

New = New

Refi = Refinance

Renew =
Renewal

RenewWithMod
= Renewal with
Modification

Mod =
Modification

Y y

AcctRelCode Borrower Y Y
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Element Name Description
Applicable
Values Required Validated

Co-Borrower

Co-Signer

Guarantor

BorwFirstName Y Y

BorwMiddleName N N

BorwLastName Y Y

BorwAddr All fields listed go to
the borrower's
physical address
record in the
corresponding
ArgoKeys fields.

StreetAddr1 Y N

StreetAddr2 N N

City Y N

StateCode Y N

PostalCode Y N

County N N

BorwTaxId Y N

BorwPhoneInfoArray N N

Phone Info – Record 1 Home Phone N N

Phone Info – Record 2 Work Phone N N

BorwBirthDt ● Date of Birth
● Not to exceed 120

years

Y Y

BorwHousingDispType All fields listed go to
the borrower's
physical address
record in the

Rent

Own

N Y
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Element Name Description
Applicable
Values Required Validated

corresponding
ArgoKeys fields.

BorwHousingTerm N N

TermCnt Calculated to number
of Years and
Months.

Months

Years

N N

TermUnits Either Months or
Years.

Months

Years

N Y

BorwMailAddr All fields listed go to
the borrower's
mailing address
record and
corresponding
ArgoKeys fields.

N N

StreetAddr1 N N

StreetAddr2 N N

City N N

StateCode N N

Postal Code N N

County N N

BorwPrevAddr All fields listed go to
the borrower's
previous address
record in the
corresponding
ArgoKeys fields.

N N

StreetAddr1 N N

StreetAddr2 N N

City N N

StateCode N N

Postal Code N N
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Element Name Description
Applicable
Values Required Validated

County N N

BorwPrevHousingDispTyp
e

Rent

Own

N Y

TermCnt Calculated to number
of Years and
Months.

Months

Years

N N

TermUnits Either Months or
Years.

Months

Years

N Y

BorwDriverLicId Y N

IdStateIssue Drivers License State
Issued

N N

IdIssueDt Drivers License Issue
Date

N N

IdIssueExpDt Drivers License
Expiration Date

N N

BorwEmplInfo Primary Employer
Record

N N

EmplName Employer Name N N

EmplTitle Employee Title/
Position

EmplAddr Borrower's Primary
Employer Address

N N

StreetAddr1 N N

StreetAddr2 N N

City N N

StateCode N N

Postal Code N N

EmplTerm N N
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Element Name Description
Applicable
Values Required Validated

TermCnt Number of Months or
Years.

N N

TermUnits Months

Years

N Y

BorwIncmInfo N N

SalaryMonthAmt Current Primary
Employee Income
Amount – Frequency
= Month

N N

SalaryBonusAmt N N

DivdIntMonthAmt N N

RentMonthIncmAmt N N

OthIncmArray N Y

OthIncmAmt Income Record
Amount

N Y

OthIncmSrcCode Alimony – A

Bonuses,
Commissions, etc. –
B

Child Support – C

Disability – D

Fellowships – F

Grants – G

Interest Dividends – I

IRA Distribution – Q

Notes Receivable –
N

Other – O

N Y
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Element Name Description
Applicable
Values Required Validated

Partnership Draws,
Distribution – P

Net Rental Income –
R

Gross Rental Income
– J

Separate
Maintenance – M

Social Security – S

Stipends – E

Student Loans – L

Tips – T

Unemployment – U

Welfare Benefits/
Public Assist – H

Worker's
Compensation – W

VA Retirement - V

OthIncmFreq Months

Semimonthly

Years

N Y

BorwPrevEmplInfo Previous
Employment

N N

EmplName Employer Name N N

EmplTitle Employee Title/
Position

(Prev) EmplAddr N N

StreetAddr1 N N

StreetAddr2 N N
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Element Name Description
Applicable
Values Required Validated

City N N

StateCode N N

Postal Code N N

(Prev) Emplterm Months and years of
employment.

N N

TermCnt Calculated to number
of Years and
Months.

Months

Years

N N

TermUnits Either Months or
Years.

Months

Years

N N

BorwDeclAppInfo Borrower
Declarations

N Y

EndorCoBorwExst 1. Are you a
guarantor, co-maker
or endorser of any
leases, contracts, or
debts?

Yes

No

N

EndorCoBorwToName If
EndorCoBorwExst
= Yes, then this field
is enabled.

N

EndorCoBorwForName If
EndorCoBorwExst
= Yes, then this field
is enabled

N

JudgementExists 2. Are there any suits
or judgments
pending against you?
radio buttons

N Y

JudgementToName The To Whom field N Y

JudgementAmt The Amount field N Y
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Element Name Description
Applicable
Values Required Validated

DeclBnkrptcy 3. Have you been
declared bankrupt in
the last 7 to 10
years? radio buttons

True

False

N Y

DeclBnkrptcyYr What year? (YYYY) N Y

DeclBnkrptcyLoc Where N Y

ForeClosureExst 4. Have you had
property foreclosed
upon or given title or
deed in lieu thereof?
radio buttons

True

False

N Y

LawsuitExst Are you a party to a
law suit? radio
buttons

True

False

N Y

OthDlqExst 7. Are you presently
delinquent or in
default on any
Federal debt or any
other loan, mortgage,
financial obligation,
bond or loan
guarantee? radio
buttons

True

False

N Y

AlimonyMainExst 6. Are you obligated
to pay alimony, child
support or separate
maintenance? radio
buttons

True

False

N Y

DownPmtBorw 2. Is any part of the
down payment
borrowed? radio
buttons

N Y

NonUSCitizen 8. Are you a U.S.
citizen? radio button

True

False

N Y
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Element Name Description
Applicable
Values Required Validated

AlienResident If ‘No’, are you a
resident alien? radio
buttons

True

False

N Y

OccupProp 3. Do you intend to
occupy the property
as your primary
residence? radio
buttons

True

False

N Y

PriorPropOwner If ‘Yes’, have you had
an ownership interest
in a property in the
last three years?
radio buttons

True

False

N Y

BorwNearRelName Nearest relative
name

N N

FirstName N N

MiddleName N N

LastName N N

BorwNearRelAddr Nearest relative
address

N N

StreetAddr1 N N

StreetAddr2 N N

City N N

StateCode N N

Postal Code N N

BorwNearRelPhone Nearest relative
phone number

N N

AssetAppInfo N N

AssetAppType Value/Description Checking

Savings

TimeDep

N Y
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Element Name Description
Applicable
Values Required Validated

Securities

LifeInsur

Auto

MoneyMkt

BrokerageAcct

NonMktSecurity

PersonalProp

AcctRecd

Partnership

Bond

Equipment

CloselyHeldStock

Other

AssetAcctId Asset Account
Number

N Y

AssetDefName Asset Description N Y

AssetValAmt Asset Current Value N Y

Collateral Information Consumer Loan Segment
Element Name Description Applicable Values Required Validated

City City of the institution
holding the collateral.

City City. C Y

Cntry Country. This field is
required if FornAddr is
True.

C Y

CollatBodyStyleCo
de

The code that represents
the manufacturer's body
style for a specific piece of
collateral.

General description
editor.

N N
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Element Name Description Applicable Values Required Validated

CollatCode It comes from the
Collateral Editor, but it
must match a collateral
item available for a
particular product passed
in. The only Collateral
Types being supported
initially are as follows:

● Title Vehicle
● Real Estate
● Unsecured
● Certificate of Deposit
● Savings
● Checking

Titled Vehicle

Real Estate

Unsecured

Certificate of Deposit

Savings

Checking

Y Y

Collateral
Information
Consumer Loan
Segment

CollatEstVal If Collateral Code equals
CD, then CollatEstVal =
Market Value.

If Collateral Code equals
the Checking or Savings,
then CollatEstVal =
Balance.

CollatExpDt The date the collateral item
expires for the consumer
loan.

CollatHolderAddr It is required if the
CollatCode does not equal
UNSC.

● StreetAddr1
● City
● StateCode
● PostalCode

Y N
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Element Name Description Applicable Values Required Validated

CollatHolderName The First and Last name
and address are required if
the CollatCode does not
equal UNSC.

Y Y

CollatHolderOnUs Identifies whether collateral
is held by the lending
financial institution.

If True, ArgoKeys
populates Institution with
the CollatInstName.

If False, ArgoKeys
populates Institution with
Other Financial Institution.

True

False

N Y

CollatId N N

CollatInstName The institution that is safe
keeping/holding the actual
collateral.

CollatIssueDt Collateral issue date.

SubType = LnCon

CollatCode = CD

CollatMake N N

CollatMeterVal N N

CollatModel N N

CollatOwnAddr The collateral owner's
address.

N/A N/A

CollatOwnAray An array of collateral
owner information.

N/A N/A

CollatOwnCode The code that defines the
collateral holder's
relationship to the borrower
or co-borrower.

Default is Blank.

I – Third Party
Individual

D - Third Party -
DBA / Sole Proprietor

C Y
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Element Name Description Applicable Values Required Validated

Open enum.

If CollatOwnCode = I, D, or
B, a first and last name is
required. For all other
values, a common name is
required.

T - Third Party –
Trust

C - Third Party –
Corporate

R - Third Party –
Partnership

M - Third Party -
Limited Partnership

Y - Third Party - Ltd.
Liability Partnership

L - Third Party - Ltd.
Liability Company

A - Third Party –
Association

O - Third Party –
Cooperative

F - Third Party -
Financial Institution

V - Third Party -
Removable Trust

B – Borrower

X – Third Party -
Other

CollatOwnCustId

CollatOwnInfo N/A N/A

CollatOwnName Collateral owner's name. N/A N/A

CollatPctOwned Percentage that is owned. N N

CollatStat Required when Collateral
= Title Vehicle.

New

Used

Y Y
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Element Name Description Applicable Values Required Validated

CollatTitleCode The code that represents
the form of ownership in a
piece of collateral.

General description
editor.

Canonical values are
from Vesting Type.

C Y

CollatValMthd MSRP

SalesPrice

Invoice

NADA

KBB

Oth

N N

CollatYr N N

ComName Full text line name of the
collateral owner. This field
is required if
CollatOwnCode is
complete.

C Y

FirstName The first name of the
collateral owner. This field
is required if
CollatOwnCode is I, D, or
B.

C Y

FornAddr Is this a foreign address? True

False

C Y

InstrmClsf If Collateral Code = CD,
then InstrmClsf = CD
Type.

Negotiable is defaulted.

If Collateral Code = SV,
then InstrmClsf =
Account Type. Savings is
defaulted if blank.

● CD

○ 104 -
Negotiable

○ 105 - Non-
Negotiable

○ 106 -
Uncertificated

N Y
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Element Name Description Applicable Values Required Validated

● SV (savings or
checking)

○ C - Checking
○ S - Savings

LastName The last name of the
collateral owner. This field
is required if
CollatOwnCode is I, D, or
B.

C Y

MiddleName The middle name of the
collateral owner.

N N

NonPurchCollatAm
t

If Collateral Code = CD,
then NonPurchCollatAmt
= Amount Pledged.

If Collateral Code =
Checking or Savings,
then NonPurchCollatAmt
= Amount Pledged.

PledgeAcctId If Collateral Code = CD,
then PledgeAcctId = CD
Number.

If Collateral Code =
Checking or Savings,
then PledgeAcctId =
Account Number.

PostalCode ZIP code of the institution
holding the collateral.

PostalCode ZIP code C Y

PropPurchaseAmt If Collateral Code = Title
Vehicle, then
PropPurchaseAmount =
Sales Price.

N N
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Element Name Description Applicable Values Required Validated

If Collateral Code = CD,
then PropPurchaseAmt =
Face Amount. Face
Amount represents the
original amount of the CD.

StateCode State of the institution
holding the collateral.

StateCode State code. This field is
required if FornAddr =
False.

List of state codes
from the state
repository.

C Y

StreetAddr1 Street address of the
institution holding the
collateral.

StreetAddr1 The street address of the
collateral owner. This field
is required if a collateral
owner is listed.

C Y

StreetAddr2 The second line of the
street address of the
collateral owner.

N N

Collateral Information Residential Real Estate Loan Segment
Element Name Description Applicable Values Required Validated

ApprDt The appraisal date.

SubType = LnRes

City City. C Y

Cntry Country.

This field is required if
FornAddr is True.

C Y

CollatLienAmt N N

CollatOwnAddr The collateral owner's
address.

N/A N/A
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Element Name Description Applicable Values Required Validated

CollatOwnAray An array of collateral
owner information.

N/A N/A

CollatOwnCode The code that defines
the collateral holders
relationship to the
borrower or co-borrower.

Default is Blank.

Open enum.

If CollatOwnCode = I, D,
or B, a first and last
name is required. For all
other values, a common
name is required.

I – Third Party Individual

D – Third Party - DBA /
Sole Proprietor

T – Third Party – Trust

C – Third Party –
Corporate

R – Third Party –
Partnership

M – Third Party - Limited
Partnership

Y – Third Party - Ltd.
Liability Partnership

L – Third Party - Ltd.
Liability Company

A – Third Party –
Association

O – Third Party –
Cooperative

F – Third Party -
Financial Institution

V – Third Party -
Financial Institution

B – Borrower

X – Third Party - Other

C Y

CollatOwnCustId

CollatOwnInfo N/A N/A

CollatOwnName Collateral owner's name. N/A N/A

CollatPctOwned Percentage that is
owned.

N N
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Element Name Description Applicable Values Required Validated

CollatTitleCode The code that represents
the form of ownership in
a piece of collateral.

General description
editor.

Canonical values are
from Vesting Type.

C Y

ComName Full text line name of the
collateral owner.

C Y

County County location of real
estate.

EmailAddr Email address.

Required if a valid
EmailType is present.

N Y

EmailType Email.

Cannot have more than
one PrimaryEmail.

PrimaryEmail N N

EstValue N N

FirstName The first name of the
collateral owner. This
field is required if
CollatOwnCode is I, D,
or B.

C Y

FornAddr Is this a foreign address? True

False

C Y

IdVerify_CType

IdVerifyArray Array of identification
query/questions and their
respective values for
customer/account
verification.

IdVerifyCode The identification code
that is used to
authenticate the
customer.

ArgoKeys jXchange User Guide 118 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Element Name Description Applicable Values Required Validated

IdVerifyDesc The description of the
identification code that is
used to authenticate the
customer.

IdVerifyQuery A description of the
query/question that could
be used for customer/
account identification
purposes.

IssLoc – Place of
Issuance

IssDt – Date of Issuance

ExpDt – Expiration Date

ConDt – Contact Date

IssState – Issued By

VerifId – Verification
Code

PrimId – Primary Id

IdVerifyQueryArr
ay_AType

Array of identification
query/questions and their
respective values for
customer/account
verification.

IdVerifyQueryDat
aType

This element identifies
what type of attributes
corresponds with the
IdVerifyQueryVal.

Dt, Decimal Integer
String

IdVerifyQueryInfo
_CType

IdVerifyQueryVal A value that corresponds
with the description of
the query/question
(IdVerifyQuery) that
could be used for
customer/account
identification purposes.

IdVerifyVal The identification value
that is used to
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Element Name Description Applicable Values Required Validated

authenticate the
customer.

LastName The last name of the
collateral owner. This
field is required if
CollatOwnCode is I, D,
or B.

C Y

MiddleName The middle name of the
collateral owner.

N N

NumUnit N N

OccupProp Applicant intends to
occupy property.

True

False

N Y

OrigPropCostAmt N N

PostalCode ZIP code. C Y

PropAddr StreetAddr1

City

StateCode

PostalCode

N N

PropLegalInfo N N

PropType SingleFamily

MultiFamily

Manufactured

Condo

Townhome

Other

N Y

ResType Princ = Principal

Secd = Secondary Home

Invest = Investment

N Y
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Element Name Description Applicable Values Required Validated

Oth = Other

StateCode State code.

This field is required if
FornAddr is False.

List of state codes from
the state repository.

C Y

StreetAddr1 The street address of the
collateral owner. This
field is required if a
collateral owner is listed.

C Y

StreetAddr2 The second line of the
street address of the
collateral owner.

N N

YrBuilt N N

YrPropAcq Collateral year property
acquired.

MH N N

YrBuilt Year collateral was built. MH N N

PropEstValue The estimated value of
real estate property.

MH N N

InsurCompAddr Collateral insurance
address. Includes
StreetAddr1,
StreetAddr2, City, and
Postal Code.

MH N N

InsurPlcyAmt Collateral insurance
policy amount.

MH N N

PhoneNum Collateral insurance
phone number.

MH N N

LotValAmt Collateral lot value. MH N N

OrigPropCostAmt Collateral original
property cost.

MH N N

YrPropAcq Collateral year property
acquired.

MH N N
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Element Name Description Applicable Values Required Validated

PropAddr Collateral Property
Address. Includes
StreetAddr1,
StreetAddr2, City,
StateCode, FornAddr,
PostalCode, and
CntryType.

MH N N

PropType Added the element and
description for PropType
to the Service Dictionary
Search for mobile home
(MH) in Residential Real
Estate Loan segment.

MH N N

ResType Resident type in
ownership for the
residential loan

MH Y Y
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ArgoKeys Application Screen Prints

Platform Product Inquiry - PltfmProdInq
ProdCode

CBRM > Platform > Product Manager > Account Type > General Info > Product Code

 

 

Return to Platform Inquiry.

RegionCode

CBRM > Maintenance > Region Editor > Region Information
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Return to Platform Inquiry.

PltfmClsfPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Return to Platform Inquiry.

TaxFavProdType

Not supported.

Return to Platform Inquiry.

BrCode

CBRM > Maintenance > Office
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Return to Platform Inquiry.

AcIntent

Not supported.

Return to Platform Inquiry.

ActIntentKey

Not supported.

Return to Platform Inquiry.

PltfmProdInfoRec / RegionDesc

CBRM > Product Manager > Account Type > General Info > Region
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Return to Platform Inquiry.

BrDesc

CBRM > Maintenance > Office
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Return to Platform Inquiry.

PltfmCatDesc

CBRM > Product Manager > General Info > Category
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Return to Platform Inquiry.

PltfmProdDesc

CBRM > Product Manager > General Info > Product Description
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Return to Platform Inquiry.

ProdCompareDesc

CBRM > Product Manager > Comparison
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Return to Platform Inquiry.

CustProfDesc

CBRM > Product Manager > General Info > Profit Code
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Return to Platform Inquiry.

IntBasisDesc

Return to Platform Inquiry.

PltfmAcctType / PlftmAcctTypeCode

CBRM > Platform > Product Manager > Account Type

● CDA = Certificate of Deposit
● DDA = Checking/Money Mkt
● IRA = Individual Retirement Account
● ILA = Installment Loan
● LTC = Letter of Credit
● LOC = Line of Credit
● TDA = Savings
● SBA = Safe Deposit Box
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Return to Platform Inquiry.

PltfmCatCode

CBRM > Platform > Product Manager > Select Account Type > Select Product > General
Info > Category
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Return to Platform Inquiry.

PltfmProdCode

CBRM > Platform > Product Manager > Account Type > General Info > Product Code
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Return to Platform Inquiry.

ProdCompareCode

CBRM > Product Manager > Comparison > Product
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Return to Platform Inquiry.

PlftmCustType

CBRM > Platform > Product Manager > General Info > Personal or Business
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Return to Platform Inquiry.

RateType

CBRM > Platform > Product Manager > Select Account Type=Installment > Select
Product > Options > Interest Rate Type
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Return to Platform Inquiry.

IntTerm

CBRM > Platform > Product Manager > Account Type=DEP/TDEP > Options > Interest
Term
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Return to Platform Inquiry.

IntTermUnits

CBRM > Platform > Product Manager > Account Type=DEP/TDEP > Options > Interest
Term
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Return to Platform Inquiry.

MktgMsg

CBRM > Platform > General Info > Marketing Message
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Return to Platform Inquiry.

ProdEffDt

CBRM > Platform > Product Manager > General Info > Effective Date
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Return to Platform Inquiry.

ProdExpDt

CBRM > Platform > Product Manager > General Info > Expiration Date
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Return to Platform Inquiry.

MinIntRate

Return to Platform Inquiry.

MaxIntRate

Return to Platform Inquiry.

InitIntRate

CBRM > Product Manager > Rate Details > Initial Rate Offer
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Return to Platform Inquiry.

InitIntRateTerm

CBRM > Product Manager > Rate Details > Initial Rate Offer > Initial Rate Term
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Return to Platform Inquiry.

InitIntRateTermUnits

CBRM > Product Manager > Rate Details > Initial Rate Offer > Initial Rate Term
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Return to Platform Inquiry.

CustProfCode

CBRM > Product Manager > Account Type=Deposit/TimeDeposit > General Info > Profit
Code
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Return to Platform Inquiry.

IntBasis

Return to Platform Inquiry.

DestProdCode

CBRM > Product Manager > Account Type > General Info > Host Code
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Return to Platform Inquiry.

PltfmProdImg

CBRM > Product Manager > General Info > Cover Page Bitmap
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Return to Platform Inquiry.

PltfmProdImgFormat

Hard code to BMP.

Return to Platform Inquiry.

PrstHTML

ProdTermArray
<ProdTermArray>
        <ProdTermInfo>         
        <ProdTermType>Ceil</ProdTermType>         
        <ProdTermUnits>Months</ProdTermUnits>         
        <ProdTermCnt>180</ProdTermCnt>
          <Ver_1 />
        </ProdTermInfo>
      </ProdTermArray>

Return to Platform Inquiry.

ProdSvcOptArray / ProdSvcOptCode

CBRM > Product Manager > Account Type=Dep/TDep > Options > Check Order / ATM/
Debit Card Setup
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Return to Platform Inquiry.

CBRM > Product Manager > Account Type=Dep/TDep > Display Options > Overdraft /
Bounce Protection / Combined Statement / Sweep Account / Relationship Priced / PC
Banking
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Return to Platform Inquiry.

ProdFeeArray

CBRM > Lending > Fee Charges > Fees > Select Search Type > Select Loan Type > Select
Modify after highlighting a fee

FeeCode=Fee Code
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Return to Platform Inquiry.

FeeDesc=Fee Name
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Return to Platform Inquiry.

FeeAmt

 

 

Return to Platform Inquiry.

DiscArray

CBRM > Product Manager > Discounts
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Return to Platform Inquiry.

CrossSellProdArray / PltfmClsPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Return to Platform Inquiry.

PltfmProdCode

CBRM > Platform > Product Manager > Account Type > General Info > Product Code
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Return to Platform Inquiry.

PltfmProdDesc

CBRM > Platform > Product Manager > Account Type > General Info > Product
Description
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Return to Platform Inquiry.

ProdCompareArray / PltfmClsPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Return to Platform Inquiry.

PltfmProdCode

CBRM > Platform > Product Manager > Product Code
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Return to Platform Inquiry.

PltfmProdDesc

CBRM > Platform > Product Manager > Account Type > General Info > Product
Description
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Return to Platform Inquiry.

DepItems / ItemTruncArray

CBRM > Product Manager > Account Type=Dep > Options > Available Check Return
Method
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Return to Platform Inquiry.

MinAmt

CBRM > Product Manager > Account Type=Dep > Options > Minimum Balance
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Return to Platform Inquiry.

TimeDepItems / MinAmt

CBRM > Product Manager > Account Type=Dep > Options > Minimum Balance

 

 

Return to Platform Inquiry.

LnItems / AlwRateLockType

Application > Platform > Account Type=Installment/LOC > Rate Details > Allow Rate
Locking
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Return to Platform Inquiry.

CollatArray / CollatCode

CBRM > Platform > Product Manager > Lending > Collateral > Collateral Types > Host
Code
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Return to Platform Inquiry.

CollatDesc

CBRM > Platform > Product Manager > Lending > Collateral > Collateral Types List >
Description

 

 

Return to Platform Inquiry.

LifetimeCapRate

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan check box selected > Interest Rate Type=Variable or Adjustable > Rate Details >
Lifetime Ceiling
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Return to Platform Inquiry.

LnCapBasisType

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan check box selected > Interest Rate Type=Variable or Adjustable > Rate Details >
Base Lifetime Cap On
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Return to Platform Inquiry.

LnRegArray

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Loan Acts
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Return to Platform Inquiry.

LnTraitArray / LnTraitType / InitialRateOffer

CBRM > Product Manager > Rate Details > Initial Rate Offer
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Return to Platform Inquiry.

AutoPayOffer

CBRM > Product Manager > Account Type=Installment/LOC > Options > Auto Payment?
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Return to Platform Inquiry.

Real Estate (RE)

CBRM > Product Manager > Account Type=Installment/LOC > Options > Line of
Business=Real Estate/Home Equity
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Return to Platform Inquiry.

Direct

CBRM > Product Manager > Account Type=Installment/LOC > Options > Line of
Business=Direct (Non-Real Estate)
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Return to Platform Inquiry.

Revolving

CBRM > Product Manager > Account Type=LOC > Options > Revolving
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Return to Platform Inquiry.

ConstOnly

CBRM > Product Manager > Account Type=Installment/LOC > Options > Construction
Loan check box > Const Only
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Return to Platform Inquiry.

ConstPrem

CBRM > Product Manager > Account Type=Installment/LOC > Options > Construction
Loan > Const-Perm
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Return to Platform Inquiry.

HELOC

CBRM > Product Manager > Account Type=LOC > Options > HELOC
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Return to Platform Inquiry.

Escrow

CBRM > Product Manager > Account Type=Installment/LOC > Options > Escrow
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Return to Platform Inquiry.

ARM

CBRM > Product Manager > Account Type=Installment/LOC > Options > ARM Loan
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Return to Platform Inquiry.

Credit Life

CBRM > Product Manager > Account Type=Installment/LOC > Credit Ins & Calcs > Is
Credit Insurance available with this product?
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Return to Platform Inquiry.

Risk Management

CBRM > Product Manager > Account Type=Installment/LOC > Risk Management >
Perform Risk Management?
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Return to Platform Inquiry.

Credit Bureau

Return to Platform Inquiry.

Prepaid Odd Days Interest

CBRM > Product Manager > Account Type=Installment/LOC > Options > Line of
Business=Real Estate/Home Equity > Prepaid Odd Days Interest
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Return to Platform Inquiry.

ARM Convertible

Return to Platform Inquiry.

MaxAmt

Return to Platform Inquiry.

MinAmt

Return to Platform Inquiry.

PeriodCapBasisType

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan check box selected > Interest Rate Type=Variable or Adjustable > Rate Details >
Periodic Cap
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Return to Platform Inquiry.

PeriodCapDown

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan > Interest Rate Type=Variable or Adjustable > Rate Details > Periodic Cap Decrease
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Return to Platform Inquiry.

PeriodCapUp

CBRM > Platform > Product Manager > Account Type = Installment/LOC > Options > ARM
Loan > Interest Rate Type = Variable or Adjustable > Rate Details > Periodic Cap Increase
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Return to Platform Inquiry.

PmtCodeArray

CBRM > Product Manager > Account Type=Installment/LOC > Options

 

 

Return to Platform Inquiry.
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PmtRoundMthd

CBRM > Product Manager > Account Type=Installment/LOC > Options > Interest Rate
Type=Variable or Adjustable > Rate Details > Payment Rounding

 

 

Return to Platform Inquiry.

PmtRoundToPct

CBRM > Product Manager > Account Type=Installment/LOC > Options > Interest Rate
Type=Variable or Adjustable > Rate Details > Payment Rounding
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Return to Platform Inquiry.

PurposeArray / PurpCode

CBRM > Platform > Lending > Purpose Editor > Purpose > Code
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Return to Platform Inquiry.

PurpDesc

CBRM > Platform > Lending > Purpose Editor > Purpose > Description
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Return to Platform Inquiry.

RateCeil

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan check box selected > Interest Rate Type=Variable or Adjustable > Rate Details >
Lifetime Ceiling
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Return to Platform Inquiry.

RateChgDt

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options >
Interest Rate Type=Variable or Adjustable > Rate Details > Rate Change Day
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Return to Platform Inquiry.

RateFlr

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Options > ARM
Loan check box selected > Interest Rate Type=Variable or Adjustable > Rate Details >
Lifetime Floor
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Return to Platform Inquiry.

RateRoundMthd

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Rate Details >
Rate Rounding
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Return to Platform Inquiry.

RateRoundToPct

CBRM > Platform > Product Manager > Account Type=Installment/LOC > Rate Details >
Rate Rounding
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Return to Platform Inquiry.

SafeBoxItems

Return to Platform Inquiry.

Platform Product Search - PltfmProdSrch
PltfmAcctTypeCode / PltfmClsfPrimType

CBRM > Platform > Product Manager > Account Type
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Return to Platform Product Search.

PltfmClsfSecdType

CBRM > Platform > Product Manager > Account Type > Checking/Money Market >
Options > Interest Type
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Return to Platform Product Search.

CBRM > Platform > Product Manager > Account Type > Savings > Options > XMAS (Club
Account) CB selected

TDA: Not Y=Regular Savings coded as R=Regular

Y=Club Account coded as X=Club

 

ArgoKeys jXchange User Guide 191 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

Return to Platform Product Search.

CBRM > Platform > Product Manager > Account Type > Installment Loan > Options >
Loan Type

S = Secured

U = Unsecured
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Return to Platform Product Search.

RegionCode

CBRM > Maintenance > Region > Region Information > ID
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Return to Platform Product Search.

PltfmCustType

CBRM > Platform > Product Manager > Select Account Type > Select Product > General
Info
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Return to Platform Product Search.

BrCode

CBRM > Maintenance > Office List

 

 

Return to Platform Product Search.
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PltfmCatCode

CBRM > Platform > Product Manager > Select Account Type > Select Product > General
Info > Category

 

 

Return to Platform Product Search.

RateType

CBRM > Platform > Product Manager > Select Account Type > Installment > Select
Product > Options > Interest Rate Type
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Return to Platform Product Search.

CollatCode

CBRM > Platform > Product Manager > Lending > Collateral > Collateral Type

 

 

Return to Platform Product Search.
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CollatDesc

CBRM > Platform > Product Manager > Select Product > Collateral > Loan Collateral >
Selected Collateral Type

 

 

Return to Platform Product Search.

PurpCode

CBRM > Platform > Lending > Purpose Editor > Purpose > Description
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Return to Platform Product Search.

PurpDesc

CBRM > Platform > Lending > Purpose Editor > Purpose > Description
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Return to Platform Product Search.

OpenFlrAmt

Deposits

CBRM > Platform > Product Manager > Deposit Account > Options > Minimum Balance
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Loans

CBRM > Lending > Policy > Policy Profiles > Select Policy Type > Minimum Loan
Amount > Modify > Minimum Amount
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Adding Policy Amounts/Terms to Products

The policy that the Minimum Amount is tied to is selected. The following is an example of
adding a Minimum Amount to an existing policy. These steps are also used to add a
Maximum Amount, Maximum Term Month, and Minimum Term Months.

1. Select a Policy Type value.
 

 
2. Highlight the Product Description and select Modify.

 

 
3. Highlight the Minimum Loan Amount and select Modify.
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4. Select the Active check box and select a value from the Level drop-down list.

 

 
5. Enter a Minimum Amount value and select Add.
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6. Select a policy via Product Manager.

CBRM > Product Manager > Select Product > Policy

 

 

Return to Platform Product Search.

OpenCeilAmt

Loans
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CBRM > Lending > Policy > Policy Profiles > Select Policy Type to Modify > Highlight
Maximum Loan Amount > Select Modify > Maximum Amount

See OpenFlrAmt for adding to products.

 

 

Return to Platform Product Search.

PlnType

CBRM > Platform > Product Manager > Deposit Account > Options > Health Savings
Account
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Return to Platform Product Search.

ProdTermUnits

Deposits

CBRM > Platform > Product Manager > Deposit Product > Options > Term Ranges

 

 

Loans

CBRM > Product Manager > Select Product > Options > Highlight Installment > Select >
Allowed > Select Payment Frequency
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Return to Platform Product Search.

ProdTermFlr

Deposits

CBRM > Platform > Product Manager > Deposit Product (CD/IRA) > Options > Term
Ranges
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Loans

CBRM > Lending > Policy > Policy Profiles > Modify > Highlight Minimum Term in
Months > Modify > Minimum Term in Months

NOTE
See OpenFlrAmt for adding to products.
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Return to Platform Product Search.

ProdTermCeil

Deposits

CBRM > Platform > Product Manager > Deposit Product (CD/IRA) > Options > Term
Ranges
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Loans

CBRM > Lending > Policy > Policy Profiles > Modify > Highlight Maximum Term in
Months > Modify > Maximum Term in Months

NOTE
See OpenFlrAmt for adding to products.
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Return to Platform Product Search.

LnTraitType

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options

LoanTraitType (Cont'd)

Direct

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options > Line of
Business

 

 

Return to Platform Product Search.

LoanTraitType (Cont'd)

Real Estate (RE)

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options > Line of
Business
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Return to Platform Product Search.

LoanTraitType (Cont'd)

ConstOnly=Construction Only

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options > Construction
Loan > Const Only
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Return to Platform Product Search.

LoanTraitType (Cont'd)

ConstPerm=Construction to Perm

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options > Construction
Loan > Const-Perm
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Return to Platform Product Search.

LoanTraitType (Cont'd)

AutoPayOffer

CBRM > Platform > Product Manager > Loan Product (ILA/LOC) > Options > Auto
Payment?
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Return to Platform Product Search.

LoanTraitType (Cont'd)

LOC - Revol

CBRM > Platform > Product Manager > Loan Product (LOC) > Options > Options Group
Box > Revolving
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Return to Platform Product Search.

LoanTraitType (Cont'd)

HELOC

CBRM > Platform > Product Manager > Loan Product (LOC) > Options > HELOC
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Return to Platform Product Search.

PltfmProdDesc

CBRM > Product Manager > General Info > Product Description
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Return to Platform Product Search.

RegionDesc

CBRM > Product Manager > General Info > General Information Group Box > Region
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Return to Platform Product Search.

PltfmCatDesc

CBRM > Product Manager > General Info > General Information Group Box > Category
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Return to Platform Product Search.

PmtCode

CBRM > Product Manager > Select Loan Product > Options > Defaults > Payment Type
Default
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Return to Platform Product Search.

RateIdxDesc

CBRM > Product Manager > Loan Product > Options > Defaults > Index Type Default

 

 

Return to Platform Product Search.

Deposit Platform App Add - PltfmAppAdd
CommAuthCode
New Account > Account > Entity Resolution/Authorization > Power
 

ArgoKeys jXchange User Guide 221 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

EstbPersonTitle
New Account > Account > Title
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ComName (EstbPersonName Complex)
New Account > Account > Name
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CommAuthCode
New Account > Account > Entity Resolution/Authorization > Power
 

 

SigNumCnt
New Account > Account > Entity Resolution/Authorization > Number of Signatures
Required to Exercise Power
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Power
New Account > Account > Entity Resolution/Authorization > Define Powers to be
Granted > Power

● Basic Powers - 1–7 powers
● Extended Powers - 1–13 powers
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CommAuthType
New Account > Account Tab > Entity Resolution/Authorization > Basic Powers or
Extended Powers
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AcctTitle

PltfrmAppActnType = LoadAcct
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Return to Deposit Platform App Add.

CRARec

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Address > Address Attributes
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Return to Deposit Platform App Add.

ProdCode

CBRM > Platform > Product Manager > Account Type > General Info > Product Code
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Return to Deposit Platform App Add.

RegionCode

CBRM > Maintenance > Region > Region Information
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Application > Platform > Work Online App > Retrieve Customer Application > Continue.
The Online Product Group Box Region correlates to the name associated with the Region ID in
CBRM.

 

 

Return to Deposit Platform App Add.

BrCode

CBRM > Maintenance > Office > ID

 

 

Application > Platform > Workline App > Retrieve Customer Application > Continue > Add
Product > Continue > Select Account Ownership Type > Select and Add each customer's
Relationship > Setup > Account > Branch

 

ArgoKeys jXchange User Guide 231 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

Return to Deposit Platform App Add.

AcctOwnType

CBRM > Account Ownership Editor. Select an Account Type to enable Account
Ownership.
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Application > Platform > Work Online App > Retrieve Customer Application > Continue.
Add the product, and then select Continue. Next, in the Account Ownership section, select
Ownership Type from the drop-down list.

 

 

Return to Deposit Platform App Add.

PltfmClsfPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Application > Platform > Work Online App > Retrieve Customer Application > Continue >
Online Product Group > Account Type

Return to Deposit Platform App Add.

PltfmOwnCode

CBRM > Account Ownership Editor, then select an Account Type to enable the Host Code.
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Return to Deposit Platform App Add.

SrcFundsCode

CBRM > Platform > Source of Funds Editor > Item Code

 

 

Return to Deposit Platform App Add.
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PrimSrcFundsType

CBRM > Platform > Source of Funds Editor > Source Type
 

 

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Input > Source Type

 

 

SrcFundsAmt

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Input > Amount
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Return to Deposit Platform App Add.

ODPrvlgOptVal

CBRM > Platform > Product Manager > Account Type > Display Options > Card Opt-In

 

 

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Customer > Relationship > Add > Setup > Overdraft > Card Opt-In

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info
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Return to Deposit Platform App Add.

UserDefTxt

CBRM > Platform > Required User-Defined Fields Editor

 

 

FedWithCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Account > Withholding Reason
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AcctClsfCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Account > Class Type
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DormantChgWav/SerChgWav

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Service Charge Information Group Box > Type

 

 

StmtCycle

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Statement Cycle
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SerChgCycle

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Service Charge Cycle
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IntCycle

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Interest Cycle
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IntDisp

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Payment Method
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IntDispAcctType

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Type
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IntDispAcctId

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Payment Method > Checking/Money Mkt > Type >
Number

 

 

PrimeRateIdx

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Override Rate
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RateRevDt

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Review Date
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RateVarCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Enter Variance > Variance Type
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RateVar

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Variance
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RateRevTerm

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Review Date > Opening Info > Review Term
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RateFlr

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Floor
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RateCeil

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Ceiling
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RateRevTermUnits

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Review Date > Opening Info > Review Term
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CallRptCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Details > Call Report Code
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CRARec

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Address > Address Attributes
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IRSExmpCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Account > Exempt Recipients > Exempt Code > Exempt Payee Code
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OffInfoArray

OffCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Select
Deposit Product > Add > Continue > Account > Officer Search > Primary Officer > Select
Officers
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OffRmk

CBRM > Branch > General Description Editor > Select Application = Common > Select
Type = Banker Role Code > Select Region or All

 

ArgoKeys jXchange User Guide 256 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019
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StmtPasCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Select
Savings Product > Add > Continue > Details > Statement or Passbook Savings
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ScsrCstdnName

Application > Platform > Work Online App > Retrieve Customer > Continue > Select
Deposit Product > Add > Continue > Select UTMA or UGMA Ownership and
Relationship > Account > Successor Custodian Information > Name of Successor
Custodian
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SigNumCnt

Application > Platform > Work Online App > Retrieve Customer > Continue > Select
Deposit Product > Add > Continue > Opening Info > Account Information > Number of
Signatures Required
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ProdSvcOptArray

Application > Platform > Customer > Continue > Deposit Product. User receives the
following message: 40279 – Would you like to view your Online Application Summary for
customer interest in Product Service Options?
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Select Yes to view the service options on the Online Application Summary.
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ItmTrunc

CBRM > Platform > Product Manager > Options > Available Check Return Method

Application > Platform > Work Online App > Retrieve Customer > Continue > Select
Deposit Product > Add > Continue > Details > Item Truncation/Safekeeping

 

 

SerChgWavRsnCode
Application > Platform > Session Manager > Begin > Account Type > Account Number >
Date > Waive Reason
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SerChgWavExpDt
Application > Platform > Session Manager > Begin > Account Type > Date > Waive
Expiration
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BenfAddrInfo
Application > Platform > Work Online App > Retrieve Customer > Continue > Deposit
Product > Add > Continue > Add > Setup > POB Beneficiaries
 

 

AcctLvlSecCode
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Account > Security Override
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Time Deposit Platform App Add - PltfmAppAdd
EstbPersonTitle
New Account > Tab > Title
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EstbPersonName
New Account > Account > Name
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SigNumCnt
New Account > Account > Entity Resolution/Authorization > Number of Signatures
Required to Exercise Power
 

 

CommAuthCode
New Account > Account > Entity Resolution/Authorization > Define Powers to be
Granted > Power

● Basic Powers - 1–7 powers
● Extended Powers - 1–13 powers
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CommAuthType
New Account > Account Tab > Entity Resolution/Authorization > Basic Powers or
Extended Powers
 

ArgoKeys jXchange User Guide 269 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

ProdCode

The Product Code is defined in Product Manager and is not visible in the ArgoKeys application.
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CBRM > Platform > Product Manager > Product Code

 

 

Return to Time Deposit Platform App Add.

ACHCrAcctId
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info
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IntPmtStrtDt
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Payment Start Date
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IntDayMonth
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Day of Month to Pay
 

 

ACHCrName
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info
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ACHCrRtNum
Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info
 

 

RegionCode

CBRM > Maintenance > Region > ID
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Application > Platform > Work Online App > Select Customer > Retrieve Customer >
Region. The Region field correlates to the name associated with the Region ID from CBRM.

 

 

Return to Time Deposit Platform App Add.

CRARec

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Address

 

 

BrCode

CBRM > Maintenance > Office
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Application > Online Work Application > Retrieve Customer > Continue > Add Product >
Continue > Ownership Type. Then select and add each customer's relationship. Next, select
Setup > Account > Branch.

 

 

Return to Time Deposit Platform App Add.

AcctOwnType

CBRM > Platform > Account Ownership Editor. Select an Account Type to enable Account
Ownership.
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Application > Platform > Work Online Application > Customer. Select Continue if it is an
existing customer. If not, complete the new application process for new customers. Then select
Continue > Add Product > Continue > Account Ownership > Ownership Type.

 

 

Return to Time Deposit Platform App Add.

CallRptCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Detail
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IssDt

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info
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CDTerm

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info

 

 

CDTermUnits

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info
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MatDt

Application > Platform > Work Online App > Retrieve Customer > Continue > Deposit
Product > Add > Continue > Opening Info
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ACHTrnCode

Application > Platform > Work Online App > Continue > Product > Add > Continue >
Additional Info > Payment Method > Payment Method > ACH

 

 

ACHCrRtNum

Application > Platform > Work Online App > Continue > Product > Add > Continue >
Additional Info > Payment Method > Payment Method > ACH
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ACHName

Application > Platform > Work Online App > Continue > Product > Add > Continue >
Additional Info > Payment Method > Payment Method > ACH
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IntDispAcctType

Application > Platform > Work Online App > Continue > Product > Add > Continue >
Additional Info > Payment Method

 

 

IntTerm

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Interest Term
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IntTermUnits

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info
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IntYrBaseCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info > Year Base

 

 

PenCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Penalty Type
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PltfmClsfPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Application > Platform > Work Online App > Retrieve Customer > Continue > Online
Product > Account Type

Return to Time Deposit Platform App Add.

PltfmOwnCode

CBRM > Account Ownership Editor > Account Type
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Return to Time Deposit Platform App Add.

SrcFundsCode

CBRM > Platform > Source of Funds Editor > Item Code

 

 

Return to Time Deposit Platform App Add.
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PrimSrcFundsType

CBRM > Platform > Source of Funds Editor > Source Type

 

 

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Input > Source Type

 

 

Return to Time Deposit Platform App Add.

SigNumCnt

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Number of Signatures Required
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StmtFreqCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Statement Freq
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IntDispAcctId

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Additional Info

 

 

SrcFundsAmt

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Input > Amount

 

 

Return to Time Deposit Platform App Add.

UserDefTxt

CBRM > Platform > Required User - Defined Fields Editor
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Return to Time Deposit Platform App Add.

PlnCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Opening Info > Plan Type
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Return to Time Deposit Platform App Add.

PlnFeeCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Plan > Fee
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Return to Time Deposit Platform App Add.

SpousPlnCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Plan > Spousal IRA?
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Return to Time Deposit Platform App Add.

SoleSpousDistCode

Application > Platform > Work Online App > Retrieve Customer > Continue > Product >
Add > Continue > Plan > Sole Spousal Distribution
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Return to Time Deposit Platform App Add.

RateVar

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Opening Info Tab > Variance
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RateRevTerm

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Opening Info Tab > Review Term
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RateRevDt

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Opening Info Tab > Review Date

 

 

RateFlr

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Opening Info Tab > Floor
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RateCeil

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Opening Info Tab > Ceiling
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CRACountyCode

Application > Platform > Work Online App > Customer > Continue > Product > Add >
Continue > Address Tab > County

 

 

ScsrCstdnName

Application > Platform > Work Online App > Customer > Continue > Deposit Product >
Add > Continue > UTMA or UGMA Ownership and Relationship > Account Tab >
Successor Custodian Information > Name of Successor Custodian
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SigNumCnt

Application > Platform > Work Online App > Customer > Continue > Deposit Product >
Add > Continue > Opening Info Tab > Account Information > Number of Signatures
Required
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AcctLvlSecCode
Application > Platform > Work Online App > Customer > Continue > Deposit Product >
Add > Continue > Account > Security Override
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Deposit and Time Deposit Customer Segment
NAICSCode
Search > Create New Customer > Select Customer Information > Demographics > NAICS
Code
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StdIndustCode

Standard Industry Class Search > Create New Customer > Customer Information >
Demographics > Standard Industry Class
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BenflOwnExclCode
Search > Create New Customer > Customer Information
 

 

ReqLegalEntityType
Search > Create New Customer > Customer Information > FinCEN Legal Entity
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StIndustCode
Search > Create New Customer > Select Customer Information > Demographics >
Standard Industry Class
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PersonName / ComName

All customers listed in the Online Applicant group box must be added to the Customers Located
group box.

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Cover > Title.

 

 

Return to Deposit and Time Deposit Customer Segment.

FirstName

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Cover > First.

 

 

Return to Deposit and Time Deposit Customer Segment.

LastName

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Cover > Last.
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Return to Deposit and Time Deposit Customer Segment.

CustType

Application > Platform > Work Online App > Highlight Customer > Search > Customer
Type

 

 

Return to Deposit and Time Deposit Customer Segment.

BirthDt

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Demographics > Date of
Birth.

 

 

ArgoKeys jXchange User Guide 307 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



Return to Deposit and Time Deposit Customer Segment.

TINCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Tax ID Type.

 

 

Return to Deposit and Time Deposit Customer Segment.

TaxId

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Tax ID Number.

 

 

Return to Deposit and Time Deposit Customer Segment.

CertCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > TIN
Certification.
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Return to Deposit and Time Deposit Customer Segment.

CertCodeDt

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > TIN Status Date.

 

 

Return to Deposit and Time Deposit Customer Segment.

BrCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Branch.
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Return to Deposit and Time Deposit Customer Segment.

IdVerifyQueryArray

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Multiple IDs.

 

 

Return to Deposit and Time Deposit Customer Segment.
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IdVerifyCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Multiple IDs >
Verification Code.

 

 

Return to Deposit and Time Deposit Customer Segment.

IdVerifyVal

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Multiple IDs >
Identification Number.

 

 

Return to Deposit and Time Deposit Customer Segment.

AddrInfo / StreetAddr1

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > Address (No P.O.
Box).
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Return to Deposit and Time Deposit Customer Segment.

City

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > City.

 

 

Return to Deposit and Time Deposit Customer Segment.

StateCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > State.
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Return to Deposit and Time Deposit Customer Segment.

PostalCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > Zip.

 

 

Return to Deposit and Time Deposit Customer Segment.

CntryType

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > Foreign.
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Return to Deposit and Time Deposit Customer Segment.

AddrCat2Use

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > Physical Address
of Customer.

 

 

Return to Deposit and Time Deposit Customer Segment.

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > IRA Address >
IRA Address.
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Or select the Use this address for IRS Address check box if the physical address is to be
used for the IRS Address.

 

 

Return to Deposit and Time Deposit Customer Segment.

AddrCatUse

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Address > Mailing Address.
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Or select the Use Physical Address for Customer Mailing Address check box to use the
physical address for the customer mailing address.

 

 

Return to Deposit and Time Deposit Customer Segment.

CustClsfCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Class Type.
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AlienResident

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Tax ID Type.
When Tax ID Type is an IRS reportable type, Alien Customer appears.
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AlienW8Type

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search > New Customer > OK > Customer > Tax ID Type >
Alien Customer. The Alien Info tab appears.
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HldMailCode

Select Application > Platform > Work Online App. Select a customer from the Online
Applicant group box, and then Search for a Customer > OK > Close > Continue > Add >
Continue > Continue > Select Customer > Separate Mailing.
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ClubPln

Select Application > Platform > Work Online App > Retrieve Customer > Continue >
Deposit > Add > Continue > Details > Club Payment Plan.
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Loan Platform App Add - PltfmAppAdd
ProdCode

CBRM > Platform > Product Manager > Account Type > General Info > Product Code
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Return to Platform App Add Application Loan Information.

BrCode

CBRM > Maintenance > Office

 

 

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Toolbox > Tracking > View > Origination Office Group Box > Office
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Return to Platform App Add Application Loan Information.

RegionCode

CBRM > Maintenance > Region Editor > Region Information

 

 

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Toolbox > Tracking > View > Origination Office Group Box > Region

 

 

Return to Platform App Add Application Loan Information.
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PltfmClsfPrimType

CBRM > Platform > Product Manager > Account Type

 

 

Return to Platform App Add Application Loan Information.

ProceedAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Requested Terms and Purpose Group Box > Amount

 

 

Return to Platform App Add Application Loan Information.

RateIndxDesc

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Index Type

NOTE
The Index Type is only visible with Rate Type values of Variable or Adjustable.
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PmtCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Requested Terms and Purpose Group Box > Pmt Type

 

 

Return to Platform App Add Application Loan Information.
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BallPmtAmount

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Payment Amount

 

 

Return to Platform App Add Application Loan Information.

LnTerm

The Payment Term (Pmt Term) consists of the Term Count (Number of Payments) and Term
Units (Payment Frequency).

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Requested Terms and Purpose Group Box > Pmt Term

 

 

Return to Platform App Add Application Loan Information.
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FirstPmtDt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Application Config > First Payment

 

 

Return to Platform App Add Application Loan Information.

LnAppType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Purpose > Application Type Group Box > Application Type

 

 

Return to Platform App Add Application Loan Information.

AcctRelCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Borrower Summary Group Box > Type
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The Account Relationship Code (Applicant Relationship Type) can also be accessed
through Required Information and the Applicant Notebook.

Return to Platform App Add Application Loan Information.

BorwFirstName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > First Name

 

 

This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.
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BorwMiddleName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Middle Name

 

 

BorwLastName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Last Name

 

 

This information can also be accessed through the Required Info button.
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Return to Platform App Add Application Loan Information.

StreetAddr1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > Address

 

 

This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.

StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > Address
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Return to Platform App Add Application Loan Information.

City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > City

 

 

This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.
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StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > State

 

 

This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.

PostalCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > Zip
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This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.

County

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Address Information Group Box > County

 

 

Return to Platform App Add Application Loan Information.
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BorwTaxID

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Tax ID Number

 

 

This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.

Phone Info - Record 1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Home Phone
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Return to Platform App Add Application Loan Information.

Phone Record 2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Work Phone

 

 

Return to Platform App Add Application Loan Information.

BorwBirthDt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Information > Applicant
Information Group Box > Date of Birth
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This information can also be accessed through the Required Info button.

Return to Platform App Add Application Loan Information.

BorwHousingDispType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Housing Type

 

 

Return to Platform App Add Application Loan Information.
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BorwHousingTerm / TermCnt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Length of Residence

 

 

Return to Platform App Add Application Loan Information.

TermUnits

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Physical
Address > Modify > Length of Residence > Years or Months
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BorwMailAddr / StreetAddr1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > Address
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StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > Address
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City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > City
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StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > State
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PostalCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > Zip
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County

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Mailing
Address > Modify > County
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BorwPrevAddr / StreetAddr1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Previous
Address > Modify > Address
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StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Previous
Address > Modify > Address
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City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Previous
Address > Modify > City
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StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Previous
Address > Modify > State
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Postal Code

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address > Address Type=Previous
Address > Modify > Zip
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County

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address Type=Previous Address >
Modify > County
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BorwPrevHousingDispType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address Type=Previous Address >
Modify > Length of Residence

TermCnt
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TermUnits

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Address Type=Previous Address >
Modify > Length of Residence > Length of Residence
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BorwDriverLicId

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Applicant ID's >
Identification Group Box > Identification Type/Identification Number
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BorwEmplInfo / EmplName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Employer

 

 

EmplTitle

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Position
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EmplPrimType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current

 

 

EmplAddr / StreetAddr1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Address

 

 

StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Address
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City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > City

 

 

StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > State
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Postal Code

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Zip

 

 

EmplTerm / TermCnt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Number of Years and/or Months

 

 

TermUnits

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
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Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Years/Months

 

 

BorwIncmInfo / SalaryMonthAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > Select Status=Current >
Modify > Frequency=Month > Income Amount

 

 

ArgoKeys jXchange User Guide 357 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



SalaryBonusAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income
Source=Bonuses, Commissions, etc. > Frequency=Monthly > Amount

 

 

DivIntMonthAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income
Source=Interest Dividends > Frequency=Monthly > Amount

 

 

RentMonthIncmAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income Source=Net
Rental Income > Frequency=Monthly > Amount
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OthIncomArray / OthIncmAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income
Source=Other > Amount

 

 

OthIncmSrcCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income Source
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OthIncmFreq

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify > Income
Source=Other > Frequency

 

 

NonTaxblIncmType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Income > Modify or Add > NonTaxable
Income
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BorwPrevEmplInfo / (Prev)EmplName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Employer
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(Prev) EmplTitle

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Position

 

 

(Prev) EmplAddr

StreetAddr1

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Address

 

 

StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
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Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Address

 

 

City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > City

 

 

StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > State
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Postal Code

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Zip

 

 

(Prev) EmplTerm / TermCnt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Numbers of Years and/or Months

 

 

TermUnits

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
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Applicant > Customer Type=Borrower > Modify > Employment > State=Previous >
Modify > Length of Employment

 

 

BorwDeclAppInfo / EndorCoBorwExst

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > Are you a guarantor, co-
maker or endorser of any leases, contracts or debts?

 

 

EndorCoBorwToName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > If Yes, Are you a
guarantor, co-maker or endorser of any leases, contracts or debts? > To Whom
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EndorCoBorwToName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > If Yes, Are you a
guarantor, co-maker or endorser of any leases, contracts or debts? > For Whom

 

 

JudgementExists

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 2. Are there any suits or
judgments pending against you?

 

 

JudgementToName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 2. Are there any suits or
judgments pending against you? > Select Yes to enable To Whom

 

 

JudgementAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 2. Are there any suits or
judgments pending against you? > Select Yes to enable Amount
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DeclBnkrptcy

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 3. Have you been
declared bankrupt in the last 7 to 10 years?

 

 

DeclBnkrptcyYr

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 3. Have you been
declared bankrupt in the last 7 to 10 years? > Select Yes to enable What Year

DeclBnkrptcyLoc

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 3. Have you been
declared bankrupt in the last 7 to 10 years? > Select Yes to enable Where

 

 

ForeClosureExst

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 1. Have you directly or
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indirectly been obligated on any loan which resulted in foreclosure, transfer of title in lieu
of foreclosure or judgment (This would include such loans as home SBA loans, home
improvement loans, educational loans, manufactured (mobile) home mortgage, financial
obligation, bond, or loan guarantee.)?

 

 

LawsuitExst

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 5. Are you party to a law
suit?

 

 

OthForeClosureExst
OthForeClosureRsn

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 4. Have you had property
foreclosed upon or given title or deed in lieu thereof in the last 7 years? > Explanation

 

 

OthDlqExst

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 7. Are you presently
delinquent or in default on any Federal Debt or any other loan, mortgage, financial
obligation, bond, or loan guarantee?
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AlimonyMainExst

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 6. Are you obligated to
pay alimony, child support, or separate maintenance?

 

 

DownPmtBorw

The Mortgage Declaration tab is only visible for real estate loans.

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Mortgage Declaration > 2. Is any part of
the loan payment borrowed?

 

 

NonUSCitizen

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Declaration > 8. Are you a U.S. citizen?

 

 

AlienResident

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
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Applicant > Customer Type=Borrower > Modify > Declaration > 8. Are you a U.S.
citizen? > If "No", Are you a resident alien?

 

 

OccupProp

The Mortgage Declaration tab is only visible for real estate loans.

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Mortgage Declaration > 3. Do you
intend to occupy the property as your primary residence?

 

 

PriopPropOwner

The Mortgage Declaration tab is only visible for real estate loans.

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Mortgage Declaration > 3. Do you
intend to occupy the property as your primary residence? > Yes > If “Yes”, Have you had
an ownership interest in a property in the last three years?

 

 

PriorPropType

The Mortgage Declaration tab only visible for real estate loans.

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Mortgage Declaration > 3. Do you
intend to occupy the property as your primary residence? > Yes > If “Yes”, Have you had
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an ownership interest in a property in the last three years? > Yes > If “Yes”, What type of
property did you own?

 

 

PriorPropTitleType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Mortgage Declaration > 3. Do you
intend to occupy the property as your primary residence? > Yes > If “Yes”, Have you had
an ownership interest in a property in the last three years? > Yes > If “Yes”, How did you
hold title to the home?

 

 

BorwNearRelName

FirstName, MiddleName, LastName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative >
Name
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BorwNearRelAddr

StreetAddr1, StreetAddr2

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative >
Street

 

 

City

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative > City
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StateCode

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative >
State

 

 

Postal Code

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative > Zip
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BorwNearRelPhone

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Applicant Info > Nearest Relative >
Phone

 

 

AssetAppInfo / AssetAppType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Assets > Asset Type
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AsstAcctId

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Assets > Select Asset to Modify >
Account Number

 

 

AssetDefName

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Assets > Select Asset to Modify >
Description
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AssetValAmt

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan # Application ID > Search > Customer Account > Search >
Applicant > Customer Type=Borrower > Modify > Assets > Select Asset to Modify >
Current Value

 

 

EmailType

Application > Platform > Session Manager > Loan Search > Application Source=Branch
Anywhere or Enter Loan# Application ID > Search > Customer Account > Search >
Applicant Tab > E-mail Address
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Collateral Information Consumer Loan Segment
AccountNumber

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > Account Number
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ApprDt

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Real Estate > Modify > Property >
Date Appraised
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Balance

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = Checking >
Modify > Certificate of Deposit > Checking/Savings > Balance

 

 

CD Collateral

Application > Platform > Session Manager > Loan Search > Application Source = Branch
Anywhere or Enter Loan# Application ID > Search > Customer Account > Search >
Collateral > Certificate of Deposit
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CollatCode

CBRM > Product Manager > Lending > Collateral > Collateral Type Summary

 

 

CollatStat

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type > Modify
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CollatHolderName

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Owner > Modify

 

 

CollatHolderAddr

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Owner > Owner > Modify > Address

 

 

PropPurchaseAmt

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Titled Vehicle > Modify > Titled
Vehicle > Sales Price

 

ArgoKeys jXchange User Guide 381 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

CollatHolderOnUs

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > Institution

 

 

CollatInstName

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > Name of Institution
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CollatHolderAddr

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > Name of Institution

The Address, City, State, and Zip fields appear.
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CollatOwnArray

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Collateral Tab > RE Collateral > Owner
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Face Amount

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Face Amount

 

ArgoKeys jXchange User Guide 385 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

InstrmClsf

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > CD Type
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Checking or Savings

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = Checking >
Modify > Certificate of Deposit > Checking/Savings > CD Type

The Checking and Savings options appear.

 

 

CollatEstVal

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = Checking >
Modify > Certificate of Deposit > Checking/Savings > Market Value
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County

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Real Estate > Collateral > County

 

 

CollatIssueDt

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > CD > Modify > Certificate of
Deposit > Date of Issue
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CollatExpDt

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > CD > Modify > Certificate of
Deposit > CD Maturity Date
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CollatBodyStyleCode

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type=TV > Modify > Titled
Vehicle > Body Style

 

 

CollatTitleCode

Application > Platform > Session Manager > Verified Canonical Values in CBRM >
General Description Editor > Lending > Vesting
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Checking or Savings Collateral

Application > Platform > Session Manager > Loan Search > Application Source = Branch
Anywhere or Enter Loan# Application ID > Search > Customer Account > Search >
Collateral
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PledgeAcctId

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > CD Number
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NonPurchCollatAmt

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = CD > Modify >
Certificate of Deposit > Checking/Savings > Amount Pledged

 

 

Application > Platform > Session Manager > Loan Search > Application Source >
Search > Customer Account > Search > Collateral > Collateral Type = Checking >
Modify > Certificate of Deposit > Checking/Savings > Amount Pledged

 

ArgoKeys jXchange User Guide 393 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



 

ArgoKeys jXchange User Guide 394 © 1999-2019 Jack Henry & Associates, Inc.
ArgoKeys® Release 2020 | 05/13/2019



ArgoKeys Post-Install Steps

Application Source for Lending Applications
To track application sources for Branch Anywhere loans, an application source for Branch
Anywhere must be set up in the General Description Editor.

1. Select Lending from the Application drop-down list.
2. Select Application Source from the Type drop-down list.
3. Select Branch Anywhere from the Third Party drop-down list.
4. Select the appropriate Translation value for HMDA reporting.
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Product Filtering
To offer only products through the product search, a product must have Branch Anywhere
selected as an available third-party source.

1. In Product Manager, go to the General Info tab.
 

 
2. Select the Available for 3rd Party Setup check box, and then click the 3rd Party Products

button.
3. Ensure that the Branch Anywhere row has a check mark in the first column of the 3rd Party

Setup table.
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Account Number Generation
JHA host systems can generate new account numbers on a PltfmAppAdd request. If this
feature is enabled, then there is no reason to pass an account number in the PltfmAppAdd
request. If this feature is not enabled, then the consuming application must pass a value in
PltfmAppAdd.PltfmDepAppAdd.PltfmAppDepInfo.AccountId.AcctId.

The ArgoKeys server must have the server XSYN1.INI file AKAUTONUMDDA setting
configured to the appropriate values. Appropriate values are:

● YES - SilverLake generates the account number.
● NO - The account number is sent in.
● SAV - The account number is generated for savings and club accounts only.
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